Eevee depth of field

for some reason i never get decent quality when i turn on the depth of field checkbox. i always end up with weird artifacts on the edges of objects, no matter what settings i change/where i focus. Is there a secret ‘‘high quality’’ checkbox somewhere?

i attached a few screenshots;