EEVEE holdout/indirect only rendering not working in 2.8?

I’m experimenting with trying to render EEVEE volumetric lighting as a separate pass from the rest of a scene – with the intent of taking the EEVEE volumetric lighting (which looks great) and combining it with a Cycles render.

However, it appears that EEVEE doesn’t honor Blender’s holdout/indirect rendering features, while Cycles does.

Here’s how my scene is set up:

If I render this out using Cycles, I get exactly what I expect – I can see the (not-quite-great Cycles) volumetric lighting, but the face is not in the render – only where the light hits it:

If I take the exact same settings and render it out using EEVEE, I get this, where I see the volumetric lighting as well as the face – and the ground:

Here is the blend file: eevee holdout test.blend (752.2 KB)

Any idea what’s going on? Do I need to set something extra to make the EEVEE render behave properly, or did I stumble across a bug?

i think it’s not working yet, BUT, you can try using Holdout SHADER for the monkey:

It’s not ideal solution, but better than nothing.

1 Like

EEVEE does not support holdout in 2.80.
And it will be limited to opaque and semi-transparent Surfaces in 2.81.

EEVEE volumetrics are fast to render but very limited compared to Cycles.
And the same is true for Indirect Lighting.