Eevee:I want reflections of the HDRI background in sme objects but not in others

I’m a complete newbye with Eevee and it’s my very first scene with it. I want to give it a try.
All has become perfect and very satisfactory except the reflections in my INTERIOR SCENE of the HDRI background.
I’m having the problem of that I love the HDRI reflections on some of my objects in my INTERIOR SCENE (chrome materials, stainless steel materials , etc) but I don’t want them in my glass panels . I 've tried almost everything.
What would you do, any advice? Thanks.

Its simpler then you think, since you have a scene and the glass allready has something to face at, you need to ad a reflection plane on the surface of the glass, telling that material to reflect the scene not the envoirment light.

good luck!

1 Like

How I’m a completely newbye with Eevee, could you send me this scene?.
Your help will save my day.
In fact it’s urgent for me and my client.

Sorry I can’t I’m not at the laptop anymore, just shift+a add a reflection plane (the one next to irradiance volume and reflection probe) on top of your glass mesh, make sure the arrow is pointed towards the wall and not inside the shower cabin, and after that move it along that arrow until you see the reflection desapear, it’s like makink am invisible mirror that only acts upon reflecting surfaces
Like this

1 Like

What is it? How can I select this option? Where?
Thanks in advance.

untitled.blend (627.9 KB)

take a look at this scene. turn arround and get familiar with how reflection planes work, acording to their position on materials. slide the plane perpendicular to the cubes face and you will understand.
Since EEVEE is an real time renderer things like reflection planes and backfaced object will interact baddly in scenes like multiple transparent surfaces like my scene cube.
But blender has some hacks for that als0, sometimes it helps to adjust the reflection depth of that transparent material to al low as 0.1 to clear off some undesired effects.