EEVEE leaking outside light

Maybe just another noob question…
It will be nice to make architectural meshes in Archipack and then render in eevee… but… wen I put light outside (sun, point, …), walls on the edges don’t block light.
I made simple test with cube, light from above, remove one side… cube was not properly lit.
Is this some kind of bug or am I doing something wrong?

Hi Anton,

I have the same problem. Nobody seems to have an answer. But even with that Blender 2.8 with eevee renderer produces already amazing results.

It could be implemented on purpose because it is not supposed to be used for commercial productions yet. I really don’t know.

Eevee’s lighting uses rasterization techniques for effects like GI and shadows. What that means is that your walls need to have a certain level of thickness unlike Cycles.

Maybe if you share a .blend file showing your problem then other users could find a workaround.

Yup, forget about engineering precision – fake & exaggerate to achieve wanted results - be an artist :wink:

Hello, did you solve this? I’ve been trying almost everything but I coulnd’t find the solution. here’s an example of the problen, even with thickness, the light keeps trespassing

I have the same problem… I am trying to make a scene where you walk on a underground tunnel until you get the exit and get out side on a clear sky landscape.
Problem is; if I want my tunnel to look dark, hen _I’m forced to put the whole world a color black. Example:


(that’s how I want my tunnel to look like)

But then that ruins the second part of the scene where on the outside I need a clear blue sky.
And if I change the world color to the Sky color I need, then this happens to my underground tunnel:


(^ so as you can see my tunnel is completely ruined)

I have tried to duplicate the tunnel and the copy a bit bigger in order to wrap and protect the original… even with 3 copies of protection, nothing. Even aplying solidify modifier to good thickness in all the meshes, nothing.

Any way to solve this ?

Try adding thickness to the outside of the mesh, using the Solidify modifier. Light leaks are usually caused by no or low mesh wall thickness.

You can also try fine-tuning the light’s Shadow and Contact Shadows settings.

In case you’re using point lights, try switching to area lights. They usually cause no or much less light leaking.

Check this post:

This doesn’t work for me if I change the point light to sun and changing its properties as instructed. I’m using blender2.8 beta feb 20 2019 version. I still have light leaks

(What/where is cascaded size settings?)

It works quite well for me with those settings. Here is a test file: sun_shadow_test.blend (633.5 KB)

It’s under Shadows settings.