EEVEE light leaking in cast shadows

Hello BA!

I’m currently learning Blender 2.8 and I have a question regarding shadows in EEVEE.
As you see in the picture, cast shadows look unrealistic as they get lighter instead of darker in corners. I tried contact shadows but this gives all kinds of artefacts / bad results

Does anyone know a solution or a good tutorial to understand how all this works?
Thank you!

Hi, check this post (and ideally read whole topic):

1 Like

Thank you so much filibis. I managed to fix my problem.

For others running against the same problem I pin pointed the main adjustments that allowed for more correct shadows.

  • set shadow method to VSM
  • high bitdepth checked
  • soft shadows checked

Important notice:

  • If you scale your geometry for some reason you get better shadows

See image below for results.



What do you mean? Object scale greater than 1?
But that will cause all sorts of problems modelling: in edit mode and with modifiers, to list just two.
I wonder if there is a scale parameter in the shadow settings that does the same in a more appropriate setting.
What is it you noticed about scale?

Maybe this, is related?

I was not clear enough. I meant scale bigger (indeed, more than 1) I don’t really understand why this happens. You don’t have to scale alot bigger to already see improvement. this behavior is independent of unit scale function (scene -> units -> units scale) for some reason.
Also, play around with lamp power as there is a threshold where a too high value will result in the same shadow problem

In my current project I have to work small so I use the unit scale function and set it about 0.001. If you don’t do this, EEVEE becomes weird and you don’t even see any shadows.

Thickness of objects affects shadows, that’s probably why scaling up provides better shadows.