Eevee lighting issues

(jessesevorg) #1

trying to render a scene and im getting issues with lighting… you can see the areas circled have incorrect reflections and light, any idea what could be causing this, driving me crazy…

1 Like
(Kevin McKraken) #2

Hey there!

Have you tried dropping the Edge Fading value in the Screen Space Reflection options?

screen

That being said, I’m not sure that this issue will go away. It seems like no matter what I change, there will always be an edge of light.

(jessesevorg) #3

gave it a shot, changes it a bit but doesnt really help it, texture bump is more rough and theres more bightness bleed in corners

(Peetie) #4

Hi, as far as I know, HDRI gives such leaks and is not suitable for EEVEE.
Test as follows: Turn HDRI of, use lights and bake again. What is the result?

1 Like
(Metin Seven) #5

Try adding thickness to the outside of the room mesh, using the Solidify modifier. Light leaks are usually caused by no or low mesh wall thickness.

You can also try fine-tuning the light’s Shadow and Contact Shadows settings.

In case you’re using point lights, try switching to area lights. They usually cause no or much less light leaking.

(Emir Sinan Gürlek) #6

Take a look at this post:

(BigBlend) #7

Can we get the blend with just the room (without the bed) so we can see if we can fix it?

(jessesevorg) #8

here i is :slight_smile: http://pasteall.org/blend/index.php?id=51054

(Eric Klein) #9

Biggest issue with this scene lighting comes from using directly an HDRI light. Enclose interior scene should not be lighted using HDRI directly. HDRI’s light create leaks and the bigger problem is that they have no shadows. An interior scene is not going to look realistic. Hopefully in a future version of Eevee HDRI limitations can be fix.

Tips for creating a realistic HDRI lighting look in Eevee for interior scenes.

  1. Make cycles render of the interior scene so the correct HDRI lighting can be visualize and use as a reference.
  2. Use a Light Path node with the Camera Ray to allow the HDRI only to be visible without affecting the illumination. See example node below:
  3. Adjust the multiplier math node to the right HDRI intensity,
  4. If the HDRI lighting is diffuse / cloudy use area lights in all or your windows. The color should the average color light coming from the HDRI.
  5. If HDRI lighting is sunny add a Sun light with same average color as the light coming from the HDRI light. Then change direction of the sun light to match the sun location/direction of the HDRI sun light.
  6. Follow my tips on light leaks at Light Leaks.
  7. Add an Irradiance Volume Probe to the interior scene and adjust the probe size, location and intensity to match the cycles render.
  8. Last add reflection cube map and enable screen space reflection.

See below example of a interior scene using diffuse/cloudy HDRI :

Cycles render:

Eevee render with Blender file without HDRI (get it from HDRIHaven) and textures.HDRI Cloudy Interior Scene Eevee_No Textures.blend (293.4 KB)

See an example interior scene with only using a sunny HDRI for lighting in Cycles that I converted to Eevee using only a Sun light for lighting.

Cycles render:
Render_Cycles

Eevee render I did make the color light warmer to improve scene look:
Render_Eevee_Shadows

7 Likes
Architectural Interiors in EEVEE Tutorial series
Realistic ArchViz from Cycles to Eevee (with tips)
Classroom Benchmark from Cycles to Eevee
Lux, Corona, Cycles