Eevee material with Alpha won't show correctly

I have 2 objects:

  1. An imported Image as Plane (2D Hand).
  2. And a simple 3d object (Paper bag).
    I was following the advice in this video.

The Alpha is working fine for #1, but not for #2. They are using the exact same nodes though. Both have their Blend Mode as Alpha Blend.

The Alpha may be working for #2, but its texture got all screwed up. I thought it was just a mater of fiddling with the Normals, but that didn’t help :frowning:

What could be the solution then?

Feel free to play with the .blend file attached herein.
eevee-Alphamat-test.blend (1.1 MB)

Thanks guys!

Maybe something like this

In newer Builds has the Principled Shader a Alpha-In.

This is great!
Thank you guys for your help :slight_smile:



I was trying to reproduce your method with the Principled Shader, but it won’t work :frowning:
Would you mind checking my file and see if you can find the reason?

Thank you so much,


DBP-help-01.blend (1.2 MB)

It looks like your graphics card or driver is causing problems.

Look at the spheres on your Screenshot.

You might be right. I am using Linux Mint. I have not tried it in Windows 10 yet.
But the texture is working again, I think all I did was to close Blender and try again. I also tried it in Blender 2.79b with Cycles, and it’s fine too.

Thanks for testing it again NV :slight_smile: