Eevee not working in 2.83

Hello, thank you for taking the time to read my post.

Installed Blender 2.83 and neither eevee or the materials show up in the viewport, solid mode works fine, not only that but also renders made in eevee don’t work, cycles works perfectly fine though. Prior to this I was using 2.82a and I didn’t have these issues with it.

Here’s an example of what I mean, in viewport eevee gets stuck with the view, and materials don’t show up at all

That is weird.
Only way, I succeed to obtain same thing in render, here with 2.83 : I have to use an holdout shader in material of Cube.
But in Viewport, Rendered Display mode looks like Material Preview mode.

Maybe material is made of an nodetree not supported by EEVEE.
Maybe, it was entirely ignore in 2.82 and now, EEVEE is trying to consider a part of it but still can’t support the rest.
What does material of Cube look like ?

1 Like

Thank you so much, it seems to be an issue with the materials, removed it and it worked.

It’s the principled BSDF that is by default on a new archive, I don’t know what may be causing this to be happening

After deleting it and adding it again now in shading and rendering it shows magenta, as if there was a texture missing
imagen

Tried with all the other BSDF and textures and it keeps having the original problem, tried repairing the files, removing blender and installing it again but the problem keeps happening

You should definitely check if your GPU drivers are up to date and if you meet the requirements (especially if you can run OpenGl 3.3)https://www.blender.org/download/requirements/

Sorry, updated the driver and it didn’t work


I was able to turn around the cube but it got those artifacts, not only that but it also affected 2.82 which worked fine before.

According to the requeriments it should work, it’s an intel HD Graphics 620

2.83 has a lot of render bugs, especially for AMD cards. Turn back to 2.82a version and wait bug fixes release. And maybe you can report this bug.

1 Like

Thank you, will do

Just giving an update, tried my luck again with 2.83.1 to see if the issue was fixed to no avail, however I hadn’t tried testing 2.90 yet so I did so and from what I can see everything works well in it.

Should I stick with 2.90 now? Sorry I don’t have that much experience with blender, is it better to wait until a 2.83 version comes out that I can work with?

Thank you

Use 2.82a, 2.83 versions is not good, and apparently will not be good.
Blender team add somethings, but broke many things. I always say: Blender team is not test enough your versions. Release 1-2 months late, but we will not met critical bugs like this.

I agree that 2.83 has many faults, I still haven’t tried out 2.83.3, because I am not sure if it will work out, 2.83.2 didn’t but 2.9 worked and it’s what I have been using because eevee works better in it than in 2.82a, thank you for your reply by the way, and sorry for taking a while to reply back

you solve it ?

Having the same issues since I updated my drivers, let me know if you could solve it please

No, never figured out a way to solve it, just moved to 2.9 and it has been the one I’ve been using since, it hasn’t given me any problems yet

1 Like

I was already on 2.9 when this happened, It was like, I updated my drivers and this happened. Now I already tried to reeinstall the drivers and go to previous versions, but it doesnt work in any of them. Im pretty worried about this cause blender is my work tool :frowning:

Sorry, can’t help with that but I hope someone can answer you.

Have you tried a previous version of 2.9 and see if that one works? Or tried out 2.91? I myself haven’t tried 2.91 yet so I dont know how it is, but maybe it could help you.

If nothing of this works maybe you could try reporting the bug and see if anyone can help you there.

I hope you can solve it

1 Like

İs probelm video card driver delete driver and restart pc still not working the Eevee
format the windows

1 Like

The bug is with soft shadows, try rolling back drivers or disabling soft shadows.

edit: for driver rollback, use DDU to cleanly uninstall current driver, then install a clean new install of older drivers.

1 Like

Solved with a downgrade on my graphics drivers! thank you all!

1 Like

If anyone it’s still getting this error, I accidentally solve this by turning on High Quality Normals on Performance tab (Render Options)image

5 Likes

tengo un problema similar con AMD r9 380, creo yo que el prolema son los drivers. Reinstalé una version anterior a los ultimos drivers y Cycles render engine sí funciona ahora pero no Evee