EEVEE output washed out

I’m having some trouble with rendering NPR content with EEVEE; Specifically, it looks like my view transform is Standard (intentional). The render preview is also in the Standard color space. but the rendered output when viewed with an external program (Quicktime player) looks much more washed out than the render preview.
I’m using the Blender 2.9 release. Left is Blender’s render window, right is Quicktime on the exported file.

How new is your Mac? What is your display set to? According to Troy, you have to render out the file with the display set to sRGB in Blender, but view it with the display set to P3 in Blender to match the color values you see in another program.

I’m using a 2018 Macbook Pro running Mac OS Mojave.
My Blender color management is sRGB/Standard/None.
My monitor color profile is the default Color LCD (in Mac Settings > Display > Color).

What do you mean by display set to P3?

Quicktime (Player) has always been a bit of an issue…
Most of these gamma issues go way back, since Apple decide to use 1.8 as a gamma value instead of 2.2 like the rest of the OS’s out there. It’s 2.2 nowadays as well…
But it’s been annoying people ever since. :wink:

Are you rendering straight to QT (get rid of this habit…), or did you convert to QT afterwards?
In both cases, it’s probably a gamma issue.

rob

What @EAW was rightfully pointing out is that you are on a modern era MacBook Pro. The hardware display you are working with is not sRGB.

Sadly, the Blender development team doesn’t care, and as such, you haven’t been looking at the correct output. Worse, the proper transform is not included by default with Blender.

So that means all of your work has been output incorrectly, and when encoded, you are getting equivalently wrong output.

The only current way to rectify this is to use a configuration that supports your hardware.

You must always set your display to the colourimetry of your actual hardware display.

I’ve been experimenting with this on and off for the past few days, and while I had initially thought I solved it (using 2.8x), when I upgraded to 2.9, I am now getting washed out renders even with my display set to Display P3.


As you can see, the saturated green of the leaves accentuates the washed-out effect. Is there anything I can do about this?

Do not change your display profile. The display profile is supposed to characterize the display. There is precisely one appropriate setting on macOS, which is typically the Color LCD for the default hardware.

In Blender, assuming you are on the Display P3 hardware, use the configuration from my repository and set your display to Apple Display P3. Pick views accordingly. Work under this setting until you wish to save the encoding for presentation. At that point, due to horrible design, you will have to change your display to the incorrect “sRGB”, and same view, and save.

Preview should match 1:1 at that point, with a minor deviation in the deep shadow, which is a tangential issue.

In summary:

  1. Use the configuration from my repository. It is the only one that supports Apple Display P3 hardware.
  2. Set display to Apple Display P3, and work.
  3. When saving, change the display to the incorrect “sRGB” with the desired view, and save to the display referred file encoding.
  4. Check in Preview to validate match.

So basically it only works for stills ? Is there a way to save an image sequence with correct encoding ?

Same applies. Just switch the “Display” to sRGB because Blender has a few critical design flaws.

1 Like

Ok I think it works. Not 100% exactly the same color but very close :slight_smile:

It should be exactly the same, except for an extremely small deviation in dark regions. Is the difference as described?

Ok so here are the steps I took. All done in default blender scene.

  1. Replaced color management folder in Blender (as per GitHub description)

  2. Set my laptop display (in settings) to ColourLCD

  3. In Blender set Color Management to Display P3

  4. Changed cube color to orange (all other settings in the scene unchanged)

  5. Change Color Managemen back to sRGB and rendered

  6. Saved result ass png.

Did I missed anything?

No that seems very much the right idea.

Where are you seeing the differences on your end?

Between rendered image in blender render view and saved file opened with Mac Preview.

I understand that. It was more of a general question regarding colours.

Could you do me a solid and render out a few tests with more prominent colours?

Did you switch your Display Device back to Apple Display P3 when you compared the two (after saving the PNG)?

2 Likes

lol :joy: you were right :slight_smile:

Another question, is there a way to make flat colours in Blender. So what I select in materials it is what I get in render (more or less)

Maybe I just should use some studio HDR, so I can predict the results?

Did @lolwel21 locate the issue? Was your display set inappropriately? Is there a match?

You’d need to be more specific.

Remember that you are defining a surface reflectance, and not an emission coming from our display. So there’s an impossible divide here. Imagine defining a surface reflectance and hitting it with no light, or low light? The authored level and the output of the render will of course not match!

With that said, there are other nuanced details at work here that are likely not terrific to confuse the surface of the question with.

An example of your issue would be of more great value at this point to make sure the question is focused on the issue.