EEVEE REFLECTION CATCHER HDRi PROBLEM

Ok lets say I am doing camera tracking and want to place a robot :robot: inside a building with reflective floor

I took a 360º picture of the place to correctly use as HDR and get good reflections for my mesh :+1:

On the floor, besides the shadow catcher I want to catch the reflection of my robot

:warning: but NOT the reflection of the HDRI environment on the reflection catcher :warning:

.
.
.

I saw some tuts with Frenel from the camera POV
but it will not work because the robot move inside the room.

Then I saw how to turn OFF the glossy on the world settings:

That kinda solves half way of the problem but not really, because

You get only the reflection of your mesh as you want, BUT

is not anymore an accurate reflection because the robot itself has lost the reflections from the HDRI

Therefore you can see the reflections of the robot are different in both pictures.

Sooo 2 questions:

  1. How could I solve this problem for EEVEE on the current version now ? :pleading_face: :pleading_face: :pleading_face:

  2. Could it be possible for the Developers that in the next versions of Blender EEVEE,

to add an option in the materials menu where you can Check / UNcheck :

:white_large_square: - CAST GLOSSY FROM HDRI ON THIS MATERIAL (for this object in particular only)
:white_check_mark: [ Yes ] :x: [ No ]
.
.

That would be sooo awesome!

Thank you for your time and help!.. :+1: :+1: :+1: