Eevee rendering issue with Radeon


I’m new to blender and have been using it for a few months now but recently upgraded to a newer computer.

I’ve poked my nose around these forums and haven’t found a solution yet, even though some issues seem pretty similar to mine yet no solutions have been made several months later.

I have this issue with Blender 2.90.1, 2.91.0, and 2.82something. (I forget the rest too many numbers)
So this issue happens in a lot of blender versions.
I have a Radeon RX 570.
My drivers are up to date, I updated them last night and it still does this.

This is the best way I can describe what’s going on.
For the record that’s the default cube, nothing added or taken away.
I’ve tried reinstalling Blender and it still did it.

Cycles works fine enough but I like Eevee a lot more for my line of work.

Any help?


Try disabling soft shadows from the render properties.

Internet: “Always update your drivers if you have an issue with something.”
The solution: “DOWNGRADE”

Thank you, kind sir/ma’am, your suggestion worked like a charm.
Any way to follow update logs or something to know when it’s safe to update the drivers? Or just trial and error?

Well, usually keeping the drivers up to date is the way to go. But sometimes there are bugs :slight_smile: Follow, not really. If you expand my previous reply you’ll find a link to the issue tracker. I guess you could subscribe to that (and similar) issues to get notified of any resolutions, but I wouldn’t call that precise.

1 Like

Having the same problem for daaaays, thank you for saving my life

1 Like

Hi. You can use rprorender for this problem. For now, that’s what I do until I find another solution.

A solution I just found. In this way, you can work with the most up-to-date drivers.

I had the same issue… Try this fix
Render settings -> Performance -> Check “High Quality Normals”
This should do the trick(worked for me).


Ohh, thanks pmax339! I had the same problem, but now it works perfectly! As pmax339 said, you must check High Quality Normals. It helped me a lot.

That did the Trick, thank you

If your node setup exceed your GPU capacity, then it can happens.

It has nothing to do with the node tree, it’s a bug in AMD drivers. High quality normals toggled on can fix it on some of the gpus, for my RX 470 I needed to toggle both the HQ normals on and toggle soft shadows off.

Then this operation exceeds your GPU.

It is literally an issue with drivers, if you roll back to older drivers there is no issue.

I use RX 570 and I met this problem many times and with many driver versions. This is not only happen when use “Soft Shadows”.

Example, you use many SSS and 4D Noise nodes on to one material and your GPU capability will exceed and this problem will occur.