Eevee screenspace refraction weird black shadow

I noticed there’s a weird second shadow in a plane with screen space refraction in Eevee. How to remove that weird duplicated shadow?

Using Blender 2.83.4

This might not be the best or proper way to do it but I usually just play with the refraction depth in the shader settings to get rid of that weirdness.

refr3

Did you also try changing the Blend and Shadow modes in the refractive material’s settings?

image

Also, using a sun light type can cause issues that are not present when using other lamp types.

I think Eevee has some limitations for the moment, if you fix your problem with the Refraction Depth value it removes the refraction effect, it might not be what you want

Yea it works, but it also remove the refraction effect. I tried setting 6m Refraction Depth and moved the ground further away from the refraction plane, it works for those under the refraction plane, but object on top of refraction plane still cause the weird “shadow”

You’re right! The refraction effect is gone after setting Refraction Depth to small value e.g. less than 1m. There’s no way to fix it?

I’m not sure it’s fixable for the moment, but I’m not Eevee expert yet :wink: