Eevee texture simplify


(alcarinque) #1

When I load a scene with big textures in eevee, blender consumes all my ram. I think this is because, for some reason, it’s copying the textures to the ram before copying them to the video ram. So, a solution would be to resize the maps so they fit better in the memory.

The simplify option has in cycles a texture size limit option which does exactly this. However, it has been removed from the eevee render settings in favor of the preferences/viewport/textures limit size option. The problem is that I don’t see this having any effect on the rendered viewport of eevee.

My current workaround is to generate a half size textures directory with imagemagick. Is this a bug? Can anyone confirm?