EEVEE: Transparency issue with internal geometry

Hi all,

I’m hoping someone can shed some light on an issue I’m having as I’ve been pulling my hair out for the last 24 hours trying to get this shader to work.

I’m trying to add a ghost to a scene I’m working on, however no matter what I do I can’t seem to get rid of the internal geometry within the mesh to make it transparent. As an example I’ve attached a quick mock-up of what I’m trying to achieve.

As you can see from the image the eyes and mouth are clearly still visible on this basemesh model. I want the character to be transparent, but not be able to see the internal parts of the mesh as well.

Any advice on how to achieve this would be greatly appreciated.

In shader set it to alpha blend…and check Backface Culling, and turn off show backface.

1 Like