Eevee viewport is much better than the render result

Hi. I have a short animation sequence with emissive particles. It looks pretty well in the viewport but a test PNG render of the shot is pixelated and poor lit and something’s weird with the bloom. I can render the viewport eventually but I’d like to know the cause.
I’m a rookie so I could miss some obvious settings.

Do you have depth of field on? Or any compositor nodes that would be creating this effect?

1 Like

I have no compositing nodes but I’ve tried to turn off depth of field and it behaves weird. It turns off in the viewport and kinda still on on the render.
Update: Now it’s weirder. I deleted the old camera, set a new one from a different angle and it still renders the old one.

Does the camera have animation data attached? That may be why it seems its rendering the same as the old camera.

Not sure still what would be the cause of the blur still though. You may want to just close out blender and see if that helps. Make sure you save your file with an extra backup of your latest changes before you do.

To be sure I deleted all the keyframes (in a copy of file), reboot blender and guess what? It’s still here. I’m damned

it looks like in the viewport you have denoising off and TAA off maybe

the top image is just the bottom image almost with blurring.

are you using the compositor nodes?

You could try adding light probes (shift + a -> light probe)
reflection cube map is a big one, so is irradiance volume

The reason this is important especially for your scene, is because you have glass. The way EEVEE works is that it projects rays from objects to the camera, and so complex reflections are lost in favor of screaming performance.

Don’t forget to bake the lights

1 Like

Could you share the .Blend file?

I’ve unchecked these two and got the viewport looking result. Again, I don’t use compositing nodes, I think these were checked by default and somehow affected render. 2019-08-30_07-41-06
Thanks to everybody responded! I’ve learned new stuff.

1 Like