Eevee viewport rendering not working

Hi, I am getting back into blender and never used eevee before - on youtube it seems everyone just goes to viewport shading and it works even with the default cube in my screenshot I directly used the file the tutorial was using. When I go into viewport render it just goes dark grey and when I scroll it basically gets lost in the void. In cycles it works perfectly. Here is an image of what is happening

I have an i7 4790 and a RX580 8gb

1 Like

I am also having the same issue of not rendering object in eevee but cycle works fine. My object goes black when i open the render viewport and there is nothing i can do. I have reinstall it multiple times but no changes.

I really hope it has nothing to do with my hardware but rather a setting

HI, the only way to find out the reason is to share a link to your file and see if we encounter the same problem.

https://www.youtube.com/watch?v=bpvh-9H8S1g&t=1024s the file is from this tutorial series by cgfast track

I have used blender for around 3 month and most of the thing that i learned i used eevee. The problem with eevee just emerge 4 days ago.

maybe using an older version will fix the problem

This could be because of your view-port shading options, when in eevee viewport click the down arrow next to the viewprot shading icons and change the settings (scene world or scene lights).

I tried those now nothing, switched both off and had singles on still same thing

Do you always have this problem or is it specific to this file?
I had a look at the video link to see if I could download the file but I do not want to create an account.

Yes, this file download requires email address. not something i want to do.

This sounds more like hardware issue to me.

I am having problem on eevee but today when i open material preview on cycle there is also a same problem of not rendering object. so i have issue on both cycle and eeve.

Here are some screenshot of my viewport so can you look at my viewport and help me…

screenshot of viewport on eevee


screenshot of viewport on cycle


no it didnt help i tried it too.

It looks like a Radeon driver issue. I’ve seen people with the same issue 4 or 5 times in the past couple of days in various places. The only advice I’ve seen them offered is wait for AMD to fix their drivers or roll back to an older driver that worked.

Or get an Nvidia card :stuck_out_tongue:

1 Like

Yeah i have radeon driver in my laptop. I updated my driver 9 day ago and i am having this problem after it so i think this is why i am facing problem in blender. Hope radeon fix this problem soon.

2 Likes

I will try this thank you, I am definitely going to invest in an Nvidia card in the future as I plan to use blender more

1 Like

I have the same problem in everything, there was a suggestion it is driver issues so I will roll back my version to see if that fixes it

Yes unfortunately John is probably right. Do not get too frustrated, I am sure that if it is a driver error they will do updates to get it working.
And yes Nvidia cards normally have very few issues- if any, I have a very low end Nvidia card (GeForce GTX 650) and apart from the fact that GPU rendering is slower than CPU it has never had problems with view-port display.

I do want to update one day and will definatly go for another Nvidia, hopefully in the future AMD will resolve its issues, there are threads talking about this and AMD techs are trying.

Sadly «trying» is not enough!

1 Like

I rolled back the driver version and all is well thank you!!

1 Like