Eeviee subsurface and alpha artifacts

Hello, I am making a game and realized that subsurface is cheap so decided to use it.
The issue is with the combination of subsurface and alpha.
When using blend alpha mode the effect is correct, but the framerate drops, so I have to use clip or hashed alpha and it results in sparkles on the render. There is no way to remove it from what I tried.


The film filter size seems to affect these artifacts but can’t solve the smaller ones, and I’m not sure it has an impact in-game.
The more transmission on the material, the less I have sparkles, but small ones (which seem to be one pixel in size) remain until it is set to 1, with the effect of disabling subsurface.
I WANT to use this feature, my scenery looks awesome with these trees dancing in the wind and having many lighting patterns, this makes the most of the game engine with a few models, there MUST be a way to deal with this flickering pixels.
Thanks.

My own answer for this is that the subsurface radius must be turned down a lot and the value for the subsurface must be increased. You find a correct balance then.

I’m not sure about the game engine, but in normal blender Eevee I think the translucency map is supposed to be used as the color of an actual translucency shader like this:


Again, I don’t know if there’s a reason not to do this for a game, but it works pretty well normally.

Very instructive.

I might do this for performance reason, will check when I get back to my place.

Now I don’t know where is the link between subsurface and translucent and right now as I sorted the issue (my own answer) the graphics are really good, I can move under a tree lit from a certain angle and see the lit back face of the leaves thanks to the material option ‘subsurface translucency’ .

Thanks.