embedded filepath in blend file

Hello, I have created a bit of a problem for myself – or maybe i should say blender has created a problem for myself.

I have been working on a character in blender for some time, when I recently decided to wipe my drive. Problem is, the blender file I am working on was originally created by a user whose profile was deleted when I wiped the drive (as well as all corresponding filepath names).

Ok, stay with me.

So when I tried to use that very same blender file on my newly wiped drive, I found that chicken exporter would not work because it could not find the appropriate filepaths for the python scripts directory. Looking a bit deeper, I found that within the .blend file itself were all these filepaths embedded into the .blend file. These filepaths were all created when the .blend file was originally created.

Ok, so now that these filepaths no longer exist, I cannot do anything with my blender file.

The only way i see to fix this is to open the .blend file in a text editor and edit the hex code by hand so that it reads the correct filepath… (not as simple at it sounds).

There must be a better way to solve this problem. Any help would be MUCH appreciated!

Well, the approach with HEX changed paths may work nicely provided you have the data needed in the new (current) drive and you know the paths. May be you can try auto replace in HEX mode of certain old path with a new path(s). It may work but it may also NOT work after such a change. In any case make some more copies of the original file so that you dont lose it :wink: If the HEX change works - save the re-worked file in another new file and you’re done! :spin:

Now more Blender’s techniques rather than hacker’s techniques… Also in case the above is NOT working OK :stuck_out_tongue:

As soon as your file is untouched, it should be readable from Blender NOT for opening but as a data-base. Sooo… You can create a new Blender file and try to copy the data from your old file. You goal will be to extract as much as possible data from the old file: objects, materials, scenes, lamps, cameras… using Append or Link (SHIFT+F1). You may be able to save most of your data in such a way. May be some additional re-working will be needed to correctly link the imported objects, etc. with some other external resources as it was in the old file…

Good luck!

ok thanks, appending everything from the previous file seemed to do the trick. However, appending everything from the previous scene has caused a new problem.

When attempting to export my animations to egg format, the console seems to export everything successfully, but it just does not create a file. If I export just the geometry, the egg file exports, no problem.

I made sure to choose Append rather than Link, but it seems like some of the armature data is not fully accessible, and therefore not able to be exported.

Any idea what’s causing this?

thanks again

Well, successful appending sound good indeed!!! :slight_smile:

Unfortunately, it is hard to say what may be the reason to not importing everything from your armature. Armatures are usually tricky to import/transfer even if they are in a completely healthy state in the source file… Re-reading your posting, I think that you may need to re-work some armature properties or revive some missing links between objects by memory. Or you’d need to create/finish the missing parts… Perhaps what’s missing is also missing in the source file, but it is possible that missing properties are impossible to import by nature in Blender…