Emission and Hdri

Whenever i’m turning on the emissions layer my scene seems to be loosing the hdri light and tone it had. Turning off visibility for the layer puts things back to normal. Still a noob so any sort of help would mean a lot! Here’s the node for emission and hdri.



forgot to mention i’m in cycles.

You have a far different node tree than I would use…I am not sure why you are adding transparency to the HDRI as using the Camera ray, it is invisible. Maybe better to set in your Film setting for transparency…
Here is a quick set-up on what I believe you’re problem might be…or how I would set it up…

I only added the glossy to Make the result of the HDRI apparent…

Thanks a lot for the response.i’ll try this out. I added a sphere around the scene and used hdri as background to hide the horizon. Didn’t know the right way to do that.