Emission Shader in Blender 2.8 is not bright as the original input texture

Hi, this new change in Blender 2.8 (Cycles/Eevee) makes me uncomfortable, and it happened to me many times.

  • Example 1: When I want to render frame images on the View 3D, then I got a weird color of images. But that problem never happened in Blender 2.79 (Cycles).
  • Example 2: When I want to have a texture exactly the same as the original texture without imperfection, I mean, I don’t want to change any color, but the result is changed color, and it’s impossible to adjust its color to be better as the original.

Please help me, or please fix that bug.

Try to change in 2.8 color management tab, filmic view transform to standard.

1 Like

Thanks, it works, but I like the “Default” (Standard) much more better than the “Filmic”, I’m wondering why did they make the Filmic the default. I’m going to report that problem to RightClickSelect that I want the “Default” (Standard) to be the default because I like it much more better.

There is no “problem” to report. The change to default filmic colour management was an intentional move on behalf of the blender devs.

@moony, OK but I will always switch to “Default” every time I create a new blend file, because every time the problem happen to me then I’ve always wanted to solve it, but the problem was always happened to me, and I like the “Default”.

I might be wrong - but i’m pretty sure you can change the default color management settings if you do the following:

If you do this - you’ll only have to change it once, then any new blend files you create will use your saved setting.

You’ll still have to manually correct any old ones however.

2 Likes

Thank, now I don’t need to change it every time I create a new file. I didn’t know that I can change the default startup settings, that’s the advantage of discussion.

I wonder if we could have a view transform selection for emission shaders. When I render at work I sometimes do image mapping directly, and I can get complaints that the image on a monitor doesn’t look same as the source. I can counter for exposure setting, but I’m clueless countering view transforms.

I’ve tried rendering with monitors off and then adding the images in post, using ID masks and UV passes, but I’m probably messing something up because the aliasing is horrible.

The above is in rare cases (curved displays), normally we add the content images in Photoshop after render because the content is never ready in time :smile: And yeah, even if I like to retain highlights by using filmic, the renders aren’t meant to be photorealistic.

1 Like

Thanks, filmic looks desaturated by default without exposure adjusting, but people in rightclickselect told me that filmic is better when there is a very bright landscape outside and we are inside a house so with the standard sRGB, we cannot see the outside because it’s too bright. But with the filmic, both inside and outside are visible because it’s using logarithmic, not a simple curve limited between 0 and 1.