Emissions in Cycles Render

Hi all,

This is my first post here and I am incredibly new to Blender, so I can only hope I’m not repeating something or just forgetting to right click or something stupid like that. But what the hey, I’m completely stumped and could really use some help.

I’ve been following Jacob Lewis’ tutorials here:

I made it as far as switching to Cycles Render when he says to create a plane, go under the materials tab in the bottom right, then create a new file there and change it to emissions while the plane is selected. Unfortunately I can’t even find materials, but the closest I found was World. It allows me to make emissions, but I don’t think it’s actually effecting the plane I have selected. Here’s a picture of what I’m looking at:

If anyone has any idea I’m all ears and thanks for reading!


Widen the properties panel on the left of the interface so you can then see the material settings or with MMB held down drag the row of icons at the top if the properties panel to show the ones that are out of view

You can also roll the mousewheel while holding your cursor on one of the tabs (camera,scene etc) to scroll left and right if i remember correctly.

…Ugh. So simple and I’ve been trying to figure that out for two days now. Thanks guys!


Here is the setup for a emission plane.

First panel top left…Is properties panel - Material tap selected with default Mateial = Diffuse.
Left click - Diffuse BSDF - A box open with all the different materiale there can be used…Pick Emission.

That’s it…Plane now have emission…And it’s the only light there are in in the render…Because I have turned World light off.
It’s last panel in the picture…Properties panel - World tap - Strength = 0.000…)

ohhh…Btw…Welcome to the forum