Emit Indirect Lighting in Volumetric Fog? How?

I need a material to emit light into an uneven fog around the material. It seemed the obvious solution was to turn on indirect lighting for the world, strong falloff so light does not scatter too much, then turn up the emit setting on the material. (Blender Render, Blender 2.65)

I can get it to work for surfaces. I can place a plane through the object and it will show the light emitted by the material.

But I can not get a volume to show the light. I can even create a volume where the surfaces are lit up by the emit material but the volume inside still does not show the emit light. (first attached)

A screen shot of my material settings is also attached.

It appears for the surfaces (faces) of the volume, the critical setting in the material node is “Refl” (reflection). But increasing the “Reflection” value for the volume material does nothing. There does appear to be an “Isotropic Volume” node listed for Blender Render (2.65), but I get an error every time I try to add it.

Is this possible?
What am I doing wrong?
Any way to accomplish what I want?
A particle system with thousands of particles as tiny spheres with the same settings as my volume above?
My computer is not that great and I am guessing such a particle system would take me ages to render. Is this correct?
Any other comments?

Thank you.

Attachments



Indirect lighting is just that, it is indirect, not direct. So it can not cast shadows.

Any other comments?

Fake it.

Here my attempt at your concept.
I have two spotlights set to very wide angle, one on top of the other, each pointing in an opposite direction inside the center of the cube. I have enabled Halo, which is is Blender Internal’s way of faking volumetrics. I have applied 4 materials to the cube, each derived from the original orange material. The only difference is that I have an increasing emit value in each copy. So the bottom row gets the material with emit = 1.0, the next row gets emit = 0.5, the next row gets emit = 0.25 and the remaining face have no emit at all.

Attachments

265_halo_inside_grid_cube.blend (114 KB)



@Atom: Interesting idea, great looking. :slight_smile:

Thanks. I tried something similar but mine did not look nearly as good as yours. I will need to play with it more.

Does “emit” do anything except when using indirect lighting? Has there eve been anything to replace the old “Radiosity”?

When Indirect Lighting is turned off, Emit acts like a blend between shading and constant color. If you set Emit to 1.0 it is the same as activating Shadeless.