emit render pass

Hi, I’m rendering a scene and later compositing it with nodes. I would like to add some glare effects on objects that emit light, but I dont know how to render a separate emit pass. I’ve checked the settings under the render layer options but nothing happens. I have also tried to turn on indirect lightning but that also doesent work. Anyone knows anything about that? (Im sorry about my english)

Yes, I can show you how to do it after I get back from work. I’ll make a screenshot.

Jes thank you a lot. You will save a lot of my time.

OK, first make sure that your object’s material does have its Emit value greater than zero.

My suspicion is that you maybe got the render pass correct but forgot to create materials and enable an Emit value. But maybe it was the render layers… anyway:

See attached image for how to set up the render passes. Make sure that you click the little camera button next to the Emit check box so that the Emit pass is not present in the combined Image pass (you don’t want to have double the emission when you composite!) I’ve also displayed the compositor window showing the two render passes with the Split View Viewer node. So from here you can add a blur, glare, or streaks to the Emit pass and then composite with the rest of the image.

At the bottom I show my 3D view with a regular cube and a smaller one with an Emit value of 0.8.

Hope this helps!

Attachments


thank you. I’ve just downloaded the newest version and it worked fine so I guess it is an alpha bug or something.