Emitter Options Missing in Blender 2.75

I can no longer access the following settings in particle systems in Blender version 2.75.
-Random
-Even Distribution
-Verts
-Faces
-Volume

Here is a screenshot of what I am talking about:

Any input on where this setting might have gone to?

They have not gone away. Show us what you see

Blender 2.75a


Ensure if you have set the particle type to hair that you have enabled the ‘Advanced’ option


This is what I see :confused:


To make any changes to the emit settings you will have to press ‘Free Edit’, then if you haven’t done so enable the ‘Advanced’ option (see my previous post for screenshot)

Thank you so much Richard! That did the trick. It is always something simple that is overlooked isn’t it?

Thanks again!