Encountered a problem in parenting.

I’ve started to try putting armatures to my first model and, after some hard work, managed to do it correctly, but I encountered a problem when I used the parenting command(Ctrl+P). When I execute the command the program goes haywire in a funny way and won’t respond to anything I do, also resulting to flickering and disappearence of the mouse arrow. The only thing I could do was to shut down Blender manually. I also tried to parent the head to the rest of the body using the same method but the exact same result repeats itself. Just to let it known, I used instructions from a tutorial I got from the Wikipedia Noob To Pro manual. If there’s something I missed here I’d gladly hear it. Thanks.

Meshes no longer need to be parented to the Armature; you can now use an Armature as a Modifier (F9) on a Mesh.

For the rest you probably need to do Ctrl-A on all objects, and Ctrl-N in edit mode with all bones selected on Armatures too.


What exactly does CTRL+A do? What I tried to do was to connect the head mesh to the body. As for the armature, do you mean that I should simply make the armature into a modifier and it would do the rest for me? I need a bit more enlightement in order to get this right.

You select the Mesh, goto F9 and open the Modifier menu and select Armature. Type in the name of the Armature Object that you want to use to modify your Mesh. Now you can decide what Method you want the armature to use to do that deformation; Envelopes (a scalable volume around each bone that affects verts within the volume) or Vertex Groups (F9 in Editmode where a group of verts is assigned and given the same name as the bone that will affect it), or both. The wikibook will give you all the details with pics:


Ctrl-A resets the Rotation and Size to zero (or one, can’t remember). To join the head to the body you need to select both (Shft-RMB) and join them into one Object with Ctrl-J. If you need to Physicaly join them you will need to Bridge them (Bridge Script in the Scripts window) or build faces manually between the two.


Thanks. I’ll try that.

Not to top-post Fligh, 'cause I’m not that good, :slight_smile: but when you rotate and scale stuff, it’s kept in a transform list… it’s your base object, then these “adjustments”. When you hit Crtl-A (Apply) it basically does nothing visible. But - now there are no post-object steps in this list, and the object is what it looks like, now as the base object.

Hope I explained that well…