env map help

i REALLY need help with env maps… the user guide tut doesnt help

How exactly do you need help?

pretty much everything %| . I cant figure out where i went wrong (the obj with the env map is always black…). If you could figure this out i’d really appreciate it! :slight_smile:

Press “centre new” in the editbuttons, and on the envmap texture settings, press “Anim”, and for the texture coordanites, press “Refl”.

I hope those instructions are clear.

Btw, why are you usind environment maps? They are outdated.

No, they aren’t.

Martin

I agree with theeth, env maps are still very useful because you can’t as yet blur raytrace reflections. I think raytrace reflections are easier to use though.

Thanks for pointing out that the env maps needed to be mapped using the refl coordinates. I was wondering why all my maps were the wrong way up. I’m still having trouble though. For some reason they don’t show transparent objects correctly and my plane is not reflecting right either.

I have the blend file here (you might have to copy/paste the url):

http://www.geocities.com/ajr650/glass.blend.zip

Env. maps can also allow you to achieve good glass and chrome effects. And I think I have heard before of blurriness in raytracing to be put in 2.34. Correct me if i’m wrong.

You’re wrong.

Martin

How could someone say env maps are outdated? I heard Pixar is using only env maps by now…

When you make you first longer animation, you’ll notice that env maps are your best friend.

For planar reflections using env maps, you need to place an empty under the plane, at the place where the camera would be mirrored. That is where the env map needs to be calculated (instead of the center of the plane).

I’m feeling a bit rusty with env maps since discovering the wonders of RayMir, however I did have a look at the .blend and here’s what I thought about the plane…

something like this:

  1. add an empty
  2. Put the empty at the same xy coordinates as the camera, but change the z coordinate - so that the empty is the same distance from the plane as the camera is, but is underneath the plane. [this assumes that the plane is parallel to the x-y axes]

ie

      .Camera

z axis
^ _______________________ plane
^

      .Empty
  1. In the env map texture for the plane, change Ob to “Empty” [you had it set as “Plane”] (and Free Data)
  2. Still in the env map texture buttons, go to buttons where it says “don’t render layer”: click on the layer where your plane is (I think you put it on 10)

Well give it a go anyway and see how you get on [!]

How big does envmap have to be? I mean dimensions.

I’m feeling a bit rusty with env maps since discovering the wonders of RayMir, however I did have a look at the .blend and here’s what I thought about the plane…

something like this:[/quote]

I know what you mean, just raymir and sit back. :slight_smile:

Thanks GCat, I did all that and it sort of went ok. I then discovered that my plane wasn’t at z=0. This meant that the camera and empty were symmetric relative to z=0 but not the plane so the reflection was a bit off.

The reflection isn’t right though. Do you know of a way to get the glass to show correctly instead of being solid? It seems to ignore transparency and refraction. I was told that env maps can handle that but I can’t get the right settings.

Pixar did the entire Toy Story 2 with env maps. They used a lot of raytracing for Finding Nemo though, so I’m not sure if they only use env maps. Like I said though, you can’t motion blur raytraced reflections can you? I guess they maybe raytrace onto an image and then blur/map it or something.

BTW, are env maps really that fast? I sometimes find that quality/speed the raytraced images in Blender are faster. I did my scene above and the envmaps weren’t recursive so they were all wrong and don’t show the glass objects right and it took 18 seconds with env maps and 12 seconds with raymir.

It depends on the object dimensions, where it is and the clearness of the reflection. Usually you don’t have to make it bigger than the render resolution. That’s why env maps can sometimes be slower if you make them too big.

Well clicking on RayMir for the plane and sphere = nice and simple and no headache!

However, this seems a bit puzzling so am still experimenting. Moving the plane to 0,0,0 helps getting the camera and Empty coordinates right. It also helps lots if you toggle the Csp and Cmir in the “map to” buttons. But it doesn’t solve the transparency problem.

Bet there’s a simple answer to this. hmmmm

I messed with the glass texture, but still no joy. (transparency and stuff.) Is it something to do with the order in which the renderer deals with objects materials perhaps? Just a guess. I mean does it do alpha stuff after environment mapping?

another discovery possibly

if you delete the glass material and render only the drink inside the glass: the mirrored image of the wine/ribena or whatever is solid material colour, whilst the wine itself is transparent…

[EDIT]…

I think I find solution at last. In the material shaders buttons, try clicking on ZTransp instead of Ray Transp

[/EDIT]

Try this one I made a long time ago to make env map reflections and chrome on a sphere:

http://bgdm0.tripod.com/spherical_envmap_tutorial.pdf

It is in PDF format, so I’m not sure if you can use it.

Hope it helps.

BgDM

Oh that works but then no refraction. I guess maybe to go the whole way you get a plugin texture that fakes refraction too. I found one for Blender but I don’t know if it works or not. I think I’ll just stick with raytracing stuff.

Thanks for the pdf BGDM. I think it covers the basics. If there was a tutorial out there that covered doing env maps with transparent objects that would be better. I don’t think they cover that in the manual, though I think they cover env mapped planes but I didn’t follow it very well.

Can’t someone answer my question?

Commodore: Best results I got where setting the resolution between 800 - 1000.

Try that and see how it works for you.

BgDM