Environment Map Scale

Hi, I am attempting to use environmental lighting in Cycles. I can get the lighting to work, but the environment map scale is all hosed up when it renders the background (in viewport render). The texture appears to be huge. I’d like to be able to scale it down so the background fits the scene size.

I applied a Texture Coordinate and Mapping node to attempt to scale it down, but the Scale parameters do not seem to have any effect.

Attached is a screen shot of part of the model with the environment map in the background (I used a generic image here to show the size issue). You can see how large it renders it.

Also attached is my node setup.

Any ideas where I am going wrong?

Attachments



IIRC its because HDRI images are 360* panoramas. Your camera setup will only be covering a small amount of this, perhaps 30* at the widest. Much like you need a wide angle lens in photography for a wide scene, you would need the camera settings in blender to have the camera wider, to see more. This also affects the perspective of whats seen.

Thanks much…after doodling with it some more I finally figured that out (duh!). So basically no matter the image size, Blender will wrap that image around a 360 degree imaginary sphere, so as you said, I only see a small portion of the image. Thanks for the info.

I also found some decent tutorials on how to manage env maps, reflection maps together.

I think we can close this issue.