EnvMap Artifacts (problem)

Hi, I’m having some issues with artifacts in the EnvMaps.

Here are the steps to replicate it:


1.- File->Load Factory Settings.

2.- Replace the default cube with an sphere (or any geometry, but spheres are better to test reflections).

3.- Link the sphere to the default material “Material” in Links and Pipeline.

4.- Change the default “Tex” Texture’s Map Input to Ref and Output to Color->add.

5.- Set the Texture Type to EnvMap.

6.- Create some random geometry so the sphere has something to reflect.

7.- Hit Render to create the EnvMap Texture.

(1) This render is fine.


Now the problem can be replicated in two ways, the most direct one is to hit the “Default Vars” button in the Texture Buttons->Preview Tab

(Since I used the default settings to begin with none of the values seems to change but the result is very diferent *2)

The other way to replicate it is to unlink the default Material and use a new one instead, repeating the remaining steps.

(2) This render is wrong (white outline artifacts around reflections).


  • CPU: AMD Athlon™ XP 2800+
  • RAM: 1024 MB
  • GFX: nVidia Geforce FX 5200 128MB
  • OS: Linux-2.6.27
  • Video Drivers: nvidia-173.14.12-2
  • Blender: 2.48a

I’m not sure if anyone has noticed this before. I’ve been looking for an answer for a while, but all I have found as a “solution” was to use Z-invert in the material but that didn’t work.

So, anyone knows what’s going on?

With these kinds of issues, it really helps if you upload the BLEND file.

My guess is when you Click default vars the premul buttons gets turned off.

Hi Atom, thanks for the reply. I just uploaded a blend (compressed and uncompressed), the sphere in the right (New Material) is the one with the problem.

Left Sphere: Steps 1-7 as in my previous post.

Right Sphere:
Created a NEW sphere (not a duplicate)
Add NEW Material (not linked with the default)
Set EnvMap as described in Steps 4-5 as in my previous post.

Render of the file:

BlendFile: (274Kb)

or compressed (83Kb)

I’ve just attached a blendfile with the issue.

I also noticed that in the 3D View preview window the material renders without any problem but the spheres dont get the sky color tone:


EnvError.blend (274 KB)

This is odd. I con inconsistently recreate this. Sometimes it goes away when I select the other sphere, turning off Bias, hitting random buttons. The sphere changes colors sometimes too, from blue (reflecting thte bg) to plain grey. This is really strange.

EDIT: It’s osa/fsa, turn it off. Or turn on Premul., like Atom suggested. Any type of anti-aliasing (OSA, FSA) without Premul produced that effect.

Thank you both for your answers.

“It’s osa/fsa, turn it off. Or turn on Premul., like Atom suggested. Any type of anti-aliasing (OSA, FSA) without Premul produced that effect.”

Turn Off OSA: Effect: inconsistency in the sky reflection. Default Material Reflects blue New Materials Reflects Grey.
[INDENT]Workaround: Unknown.
[/INDENT]Side Effect: Jagged Edges.
[INDENT]Workaround: Render Twice the size and scale it back to normal using interpolation.
[/INDENT]Premult: Effect: No Sky color in render.
[INDENT]Workaround: Compositing the background in Post or use a shadeless sphere as an skybox.
[/INDENT]SideEffect: Default Material Has Oversampled reflections New Material reflection has Jagged Edges.
[INDENT]Workaround: Unknown (Increasing EnvMap Filter Value does not help).

[/INDENT]My Workaround: Save the default Material in a .blend and append it to use as a basis for EnvMap materials (Making it single user). Can’t Use Material’s from Libraries unless the material has the Default Material as a basis too. (I noticed the problem while loading a raytraced metal material from http://www.blender-materials.org and changing the Raytrace reflections with an EnvMap).
[INDENT]Workaround: Copy the Settings of the Material Loaded from the Library to the Default Material (Yes it’s a pain).