Error: Cant set user defaults - 2.48

When I installed 2.48 it reverted to defaults I set a while ago. Which I find weird and have no clue why that happened.

In the temporary files (in tmp folder) there was a file that had all my most recent defaults (the ones that I had set before changing to 2.48) , which I made my default again. Now I decided to set new defaults, but I can’t.

When I press ctrl + u it says “save user defaults” then when I click that I get an error that says “unable to delete file” then it says “failed writing defaults:can’t change old file. file saved with @.”

Try going into the .blender directory and deleting the current B.blend and then hitting Ctrl + U. The directory should be in you programs files under Blender Foundation. Hope it works!

Thanks it worked. Anyone know why it went to defaults that I set awhile ago?

i deleted the b dlend file and tried to ctrl-u and it setill refused to save it ?

i got vista and when i delted the b blend i had to cloick on 2 windoes before i was delted

so i guess this may have to do with the protection of programme folder set by vista

but i tough as i installed blender as administrator i would use it;s power to play with that b file?

anyidea how to correct that?

Thanks

Hello.

This may happen with any Windows of the NT family (2K, XP, Vista, etc.)
It’s caused by the type of user you are: “standard”/“power user”/“administrator” or “restricted”/“limited”. Any low-privileged user will not be able to delete or modify anything in the “Windows”/“WINNT” and “Program Files” directories as well as any key in the “HKLM” (local machine) registry hive.
Before Vista, there is generally no such problems because most (incompetent and lazy) IT techs install Windows and don’t bother creating restricted user profiles. So users are working with administrative privileges all day long (which is very bad, BTW).
This changed with Vista as it automatically creates a restricted user profile.

The only way to avoid problems is to login as administrator and modify your settings.

BUT, if during the installation, you chose to have your settings in “%userprofile%” instead of “Program Files”, the setup will create all the Blender settings in the administrator’s user profile (since you must be logged in as administrator to run the setup). These settings will NOT be accessible from ANY other profile.

  1. Log in as administrator
  2. Go to “%userprofile%\Application Data”
  3. Move the “Blender Foundation” directory to your limited user profile “Application Data” directory (your user profile can be found in the \Documents and Settings<user name> directory)
  4. Change the “Blender Foundation” directory permissions (Properties > Security tab > Add button > add “Everyone” or your limited user name ; also make sure that “Full Control, Modify, R&E, …” for the added profile all have “Allow” checked)
    These may be slightly different for different versions of Windows, but the principle is the same.

Hope that helps.