Error compiling plugins on linux

When I run make on one of the blender plugins I get the error

gcc: command not found
Compile Error

Try this: locate gcc. The compiler should be installed on your machine but maybe it isn’t.

The gcc executable must be on your PATH. There is probably a (hidden) file called something like .bashrc that specifies stuff like this that will be executed at startup.

If you’re using Windows (which you are not), a different Makefile entirely is often used, because there is no “de facto choice” of development-environments there.

What version of Linux are you using? If you’re on Suse 9.1 Personal, then there is no compiler at all. If that’s the case, you might as well switch to the pro version, which has gcc – it’s still a free download and it’s just as easy to install.


Or you could just install gcc.

When I tried locate gcc it gave me a long string of directories. How do I find out which one gcc is installed in and how do I add it to the path?

Exacly what do you get when you type ‘gcc’ at the command line? I ask this because the second line doesn’t make sense compared to the first line. If GCC isn’t found, why would you get a compiler error?

On some systems, the command gcc is replaced with cc. Try typing both gcc and cc into your terminal without any arguments and see what you get.

The error I get when I type gcc is

bash: gcc: command not found

and for cc

bash: cc: command not found

Well, GCC should be included in your distro. If it isn’t, go to and follow the instructions.