"Error loading operating system" Help please :(


I recently bought a new computer, but since the bios is so new on it, most os’s don’t work unless they’re a very recent version.
Even though I’m a mac and linux guy at heart, I went the dark route and got a copy of xp.

But I’m having trouble installing it, after it goes through the file copying faze of the install, and reboots. When it trys to boot from the harddrive I get this error: Error loading operating system.
I did some google searching, and found that alot of people have had this problem, but have nto yet found a fix for it :frowning:

Here’s my specs:
Abit NF7 S2G, Nforce2 ultra 400
Amd Athlon xp 2400
Nvidia Geforce FX 5700 ultra 128
512 ram
2 60 gig maxtor ultra ATA/133

Only one of the harddrives is hooked up atm, just so that it doesn’t conflict with my linux install.

I spent about 3 straight hours trying to fix this last night, and 45 minutes this morning. And have been unable to get anywhere :frowning:
And I’ve got a lan party with some friends coming up this afternoon, so I REALLY want to get it working for that.
So please, ANY help you guys can give, would be much appreciated.

Well don’t expect any help from me. You’ve gone to the darkside and now you must suffer, muahahaha.

Ahem j/k ;).

If your Linux system is on the other removed drive, does that mean that you’re trying to boot the system on a slave drive?

I’m sure that IDE drive can only have slave or master drives and you have to install the OS onto the master drive. I knew someone who got a new hard drive and tried to install Windows and he figured out that the pins were set to slave by default. When he changed them it worked ok.

Not sure if that’s the problem though. I’ve seen reports of this bios thing. Mainly it’s about the bios not supporting the drive size:


but seeing as it’s a new system and it’s only 60GB, I doubt that’s the problem. If it is, just partition the drive.

I’ve got the drive on master. I would rather not try and attempt to install both linux and windows on a single drive.

Sorry about the double post, just wanted to say that I got it fixed :smiley: Just had to switch the drive over from Master to CS Enabled

hmmm yeah jumpers are a bastard some times LOL.

here we come SATA :wink: (LOL windows don’t even see SATA, i guess you could install a third party driver to see it though)


I got that problem

It occurred when I made a mistake in installing linux and decided to install everything from scratch.

Re-installing XP failed with that error

I was told error is in WinXP install formatting

I solved it by taking away the HD, placing it on booting machine as secondary, re-formatting it from there, and re-installing XP without touching partitions at install time

It worked

Good luck


I once had a pair of socks that almost wasn’t…


That was the most random and pointless post %|

sry… wrong topic…