Error or mistake in rendering?

Hi! everybody… i’m kinda new to Blender and i’ve made some pictures, but there’s something that occurred me in my last render, the problem is that when i render with yafray i get in some parts of a pair of meshes several “grey spaces” like spaces not rendered and i dont know why, at first i thought that it was because a vertice of a mesh within other, but i “fixed” it and it was the same result then i thought it was some mesh over the dish and it was being reflected, but there’s no mesh. so if everyone knows why this is happening to me, ill apreciate a lot if you tell me what to do, is it a problem of modeling? or light? o some value after de render, or what:confused:, i’ve been through 3 days testing adding more faces to the mesh, and recalculating normals, adding more levels in the subsurf but nothing happened:(… i put the images so you can view the real problem you quickly will notice what the problem is, it is in the saucer.

Looks like someone is wasting the black pepper :wink:

Question…do the errors occur when the scene is rendered in blender internal?

I would venture to say it is probably a normal error. Make sure all your face normals are facing outward by going into editmode, selecting everything, and pressing cntrl+N->Recalc Normals Outside.

Could also be a raydepth error. What is your current raydepth?

well, the error only occurs when i render in Yafray,blender internal doesnt have errors it works perfectly, the raydepth is 5, i’ve already done the normals thing, but i get ugly
cracks on my mesh and besides it doesnt remove the grey points. Anyway if the problem could not be solved, i will have to render with Internal. i dont have problem with it, but it appeared weird for me, and i wanted to know why is it…to dont commit that errors later.

hi daniel

I moved this thread to proper forum,(Composition, Visual Effects & Rendering moved from News & DIscussion)

since your thread is extensive from beginning I moved it, otherwise I might have locked it.
So please go to Support forums next time with similar question. Since you are new here I advice you to look first where to post before you do it.


I had problems like this before in Blender, it’s to do with raytracing and the angle of faces or something. The fix that helped me was to convert all subsurfs to raw mesh, then triangulate all quads (ctrl t).

ill try it broken…

thanks broken! your answer fixed my problem too!!!, thanks a lot, trust me i waste 3 days of work trying to find out what was wrong, houndred thanks, and ztonzy pardon me but this is the first time i write in a forum, i’ll take you advice, thanks too…