Error running 2.8 on Ubuntu 18.10 after successful compile


(Marv) #1

Hi,

since I upgraded to Ubuntu 18.10, my own blender 2.8 builds do not run anymore (Experimental builds from blender.org do run). After compilation, I get “blender built successfully”, but when starting from the terminal, I get

<jemalloc>: Error in dlsym(RTLD_NEXT, "pthread_create")
Aborted (core dumped)

I tried deleting and recompiling install_deps, used ‘make clean’ on the blender build folder, event tried a new folder - nothing seems to help - any ideas? Can you compile & run 2.8 on 18.10?


(English is not my native language) #2

install_deps.sh is a script, you have to execute it for example with:
./install_deps.sh --with-all
My old builds stopped working after running new install deps script some short time ago, mainly due to new opensubdiv.
So when you say “my own blender 2.8 build”. Do you refer to those previous builds created before running install deps script, or those builds created after running the script?


(English is not my native language) #3

If you had created Blender builds on 18.04 or earlier, you do not expect them to work at 18.10. The builds are not portable and do not include system libraries. you must recompile and build in 18.10.


(Marv) #4

I recompiled 2.8 after the ubuntu upgrade and the build would not run, then I updated the install_deps (as usual with --skip-osl) but it did not help.


(English is not my native language) #5

Each time you run install deps script it may happen that previous builds stop working. To be sure, could you try to build again right now and see if it keeps giving the same error when you try to launch blender?


(Marv) #6

I did, tried half a dozen times, it will not run, really. Must be ubuntu libraries or something.


(English is not my native language) #7

The only thing I can find with a similar error message is a bug report in which I see I had also participated:
https://developer.blender.org/T54287#490412
Perhaps you could better ask this in Blender devtalk forum:


(Marv) #8

Ok, thanks!


(Aurubus) #9

I have the exact same problem. Have you found a solution since?


#10

The libjemalloc package delivered with Ubuntu 18.10 seems to be broken. I build and installed the developent version of jemalloc from source and blender starts again (https://github.com/jemalloc/jemalloc branch:master) . Don’t forget to do a clean build including rerunning cmake after installing the library.


(Aurubus) #11

That worked, thank you!