Error, viewport -> render discrepancies

Hello I have been updating drivers and installing everything I can to try and fix this but I do not understand why it’s doing this in the first place… it seems like bad geometry but the model looks perfect to me… help??? :eek:

Attachments




Looks like the normal is flipped for that face, or it’s set to flat shade. Select them all and set them all the smooth shading, then check draw normals and if it doesn’t have a line sticking out, flip the normal for that face. Hope this helps.

Well I flipped the normal for the face, and selected all and set to smooth and am having the same issues, I am thinking its a software or hardware issue,I am running on a nvida Geforce8400 with a disabled intel integrated graphics, if that could be a problem, but I was sure I had everything up to date

Attachments



Dude… its not your hardware…
is probably a glitch… what modifiers have you run on the mesh?
I have noticed a great many aberrations on meshes… if i cant fix it i start over and am more careful in my modeling… :slight_smile: happens all the time

Why do you use the preview tool? have you actually rendered the model? does the problem show up in a render?

and that looks a lot like a flipped normal.
sorry for my multiple posts… :frowning: wasn’t my intention

It did not work… I tried deleting to see if it’s two faces I tried flipping smooth im not sure whats wrong with it…

start over.
practice makes perfect.

try deleting that entire area, (that face and a couple around it), and remodel it.

it definitely looks like a flipped normal. always blame your mesh before hardware… its easier to screw up a mesh everytime.

so, another idea is to recalculate all normals to outside which is control N… and answer yes… do this and all of the normals will point outside the mesh. you should always absolutely have all the normals pointed outside, or inside, never both directions on a single mesh, but its possible to get this wrong at some stage, hence the function to fix it

or

try and weld every vert that connects to that batch

in the edit menu title, find mesh, then automerge. turn that on. then select the verts that make up that face, one at a time. if you are finding there are edges that dont highlight, then youve got a fault. with either a tiny brush select or or area select, get the ‘single’ vert and alt M to merge it. you should get something like ‘removed 1 vert’ or something like that if it works.

Select your mesh in object mode, then Ctrl+A, select first option (can’t remember the wording).

Richard

thats a transform data menu. which i think moves the transform data up the heirarchy from the mesh to the centre. am i right?. why would that help?

If you look at the image above showing the normals, the normal lines should all be the same length but they are all different sizes and not pointing in the expected normal directions. The odd face has a very long normal line. Ctrl+A should clear the scale and rotation.

Richard

that image wasn’t there before… ive learnt about 14 things today, Richard, you just added another…

You can also try to merge all the verticies at the same location.
You could delete the left half and mirror the right one, to check if it was the left part in cause…
After, no other ideas expected that the mesh is really dense for such small details. Try to decimate it…