Everything disappears in Viewport: Solid Mode

Hello everyone –

I’m on Blender 3.0.0 (October 8 build), and in the midst of working on something I found that, weirdly, I cannot see anything in Solid Mode. I must have hit some key combination, but I’ve gone through many posts up here and each recommended solution fails to work (e.g., / key, isolation problem, normals, etc., etc.,). Everything is viewable in all other Viewport Shading modes (see images), but not in Solid Mode, which is the last image.

If anyone has any guidance on this issue it will be deeply appreciated.

Does it happen with other Blender versions ?

Actually – I thought I could open the model in 2.83, but it says there is a file format error. Not sure I can open a 3.0.0 model in 2.83.

Yes some things are not backwards compatible… any chance you can share the file ? right now I don’t see what could be causing this, since object visibility should not vary between shading modes as far as I know.

Working in Alpha or Beta versions is risky, you know. You should keep backups handy anytime you save with a version that’s considered unstable

I’d love to share the file, but it’s 427 mgs. I suppose I could put it on Google Drive.

yeah no problem I’ll take a look at it but can’t guarantee I’ll be able to solve it

Thanks a lot. If you can’t solve it, that’s okay. I really appreciate whatever help you have time for. Here it is:


It works fine for me. Xray is activated in this viewport, so everything is showing as wires. If you disable xray you should be able to see again. What I think is happening is the background color of your viewport is the same as the wire color of the objects… so they blend in and seem invisible. Try changing either your theme colors or your custom viewport color in the shading popover.

It’s a really cool scene ! Unmistakably japanese. :blush:

Thanks so much! I’ll give that a try. Will be back at the computer in about an hour or so. It’s my attempt at creating a 3D version of one of Waneela’s pixel art images. Below is the image, and a link to her work on YouTube.



1 Like

By the way – you were right. X-Ray was toggled on and it made it look invisible.

Thanks very much!

1 Like