Everything turns invisible in Cycles Rendering Viewport

Hey so this is my first time doing 3D modelling and using Blender, and I have a problem: when I change to the Cycles rendering engine all my objects turn invisible! They’re still there, like I can click where they are and it’ll highlight them as usual, but I can’t actually see the object. It’s fine if I switch to Eevee or if I go back to the regular view (where you edit and all that, the part before you start to do the rendering stuff). I’m following a tutorial on Youtube by Blender Guru and it was fine before, then recently when I went back to my file I can no longer see the objects. I don’t know if it’s something wrong with my file or if it’s just my computer. I’m not sure if I accidentally changed a setting or something or if it’s just a bug. But below are some photos of what I see. I’ve highlighted all my objects so you can tell where they are.

Here’s what I see when I go to Cycles:

Here’s what I see when I go back to the regular view (non-rendering part):

Here’s what I see when I go to Eevee:

Hey. I signed up only for help you for that problem. :smiley:

i was having same situation for 2 days and everything was invisible in cycles viewport but i could render it in cycles. i found the solution 5 minutes ago and i didn’t find any solution in any website. So maybe someone read it and solve that weird problem. Otherwise its impossible to find it. :smiley:

Solution is simple.

play

Just turn off that play button at the right top corner of viewport. right side of the shading buttons.

i pressed everything and turned on/off everything i could but nothing changed. And i realized that there is a play button and i turned that off and everything became visible like before. i think its something about with animation things and that play button making problem for now.

i hope it works for you too.

I was having the same problem. I would have a mesh object, though selectable, would show as invisible in Rendered View. I found the problem in Object Properties > Visibility > Ray Visibility. All of the boxes were unchecked. I checked Camera and viola, I could see my object.