EWOCprojects presents CreaPrim

I just uploaded version 0.7.0. It features a confirmation popup (like the 2.79 version) which points out how to remove the addon afterwards. Also, this is for Xelbayria, the popup that verifies if the addon save directory has the right permissions has been readded. So it could be CreaPrim is trying to save to a directory it doesn’t have permissions for. One solution for this is running Blender as administrator. You could also change the addon save dir, but I’m not sure how this is done. So first try this new version, it should inform you if permissions are the cause.

When I try to activate the addon it shows this.

Yes seems there was still a bug. New version 0.7.1 online. Strange the bug did not show here…

thank you.

I’ve ran a test on the new version: 0.7.1 and nothing happened? it make no sense.

I even ran the blender as administrator and I even clicked the “create Primitive” and nothing. I also check “INFO” in console and nothing about the addon show up. that’s why i find it making no sense at all.

:thinking:

@Xelbayria: ok, some remarks. First, have you selected a mesh object and are you in edit mode? I just uploaded CreaPrim 0.7.2 that hides the CreaPrim panel when these conditions are not met. Second, the new mesh object shows up in the Add->Mesh menu not the root Add menu. Wouldn’t know what else could be wrong…

No, i was never in edit mode when I selected the mesh. I can confirm that your addon is working as you intended it to.

I tried to go in Edit mode and the addon disappeared. So I returned back to Object Mode, and the addon come back. I know it’s working but :sweat:

=======================================================
I’ll try it with 2.82 to see if it work or not. I’ll let you know how it turned out.

Edit:
the result, well :sob: I don’t have to say it. Just what is it that caused the stupid issue! just a clue or an idea would be great. I want to use this addon.

I’ll tell you my steps.

  1. create a cylinder and set it with 8 sides (not 32)
  2. name it “Cylinder 8S” and chose an icon
  3. click “Create Primitive”

it’s very simple as it is. but whenever I hit “create primitive” it doesn’t show up in viewport “INFO”. but I hit “apply transform” and it does show up in INFO showing that addon is working.

:thinking: which folder that the addon is supposed to be installed in?

EDIT 1:
I’ll send the file so you can take a look to see if it’s my computer or the setting in blender that prevent the addon from doing its job.
Test.blend (780.6 KB)

let me know if you find out anything.

For me it works normal, including POPUP. However when I delete the ADDON from the primitive crash a blender. If I try to disable the addon there is also a crash

:sob: :beer: :fireworks:

alright, i got it working. it must be one of the setting from Blender 2.8x that prevent it from working properly. I don’t know what was it. Anyway, I just reset the setting to factory and it’s working now. I had to restore everything I’ve set up for my work flowing.

cheers, :beers:

Edit:
Okay, I just removed the mesh named “Test” and it crashed the blender. I am using the official 2.82 version (a version of candidate release). I did some test by creating a custom mesh and I try to add the custom mesh from the menu. so far no problem.

@Xelbayria : hurraaayy!!!

Just uploaded version 0.8.0 : the addon doesn’t crash anymore when removing/disabling freshly created primitive addons. Also the good old “menu group” functionality has been resurrected, which means you can select multiple mesh objects and CreaPrim will create a named submenu (in Add->Mesh menu) which lists all included objects (by object name).