Exclude object being reflected

Hi you blender-guys,

I’m just facing a problem I cannot solve. I created some objects
having a reflective material. Besides these there is another
object which must not be reflected by these.
In other words, how can I exclude one object from being reflected
by others? I don’t want vampires being reflected in a mirror :evilgrin:

Any suggestions?

Best regards, serum…

p.s.: I’m using yafray, not the internal scanline renderer…

Only way that comes instantly to my mind is render them separately and then composite it back together…

Maybe a too basic workaround for your purpose, but you could “fake the reflection”.
The “mirror” would just have an image of what the reflection would be, but would not mirror at all (If your camera is moving… you’ll have to make a composit). Thus your vampires could walk around with no reflection…

you could use envmap and exclude the layer in which the vampier is in :slight_smile: you’ll find envamps right near buffshadows and the dusty dinosauors bones.

Hi Guys,

thanks for your suggenstions so far. However, the
scene appears to be a little more tricky. Thus, the
workarounds you proposed might not work.

Let’s see a picture to give you an impression:


In the upper part you see the scene with the camera
selected. In front of the camera is a glass lens in order
to get the fish eye effect you can see in the lower part.
Since the cubes are reflective they show the reflection
of the lens.
How can I avoid the lens showing up and keeping the
lens effect?

Kind regards, serum…

try setting the lens shader so: Alapha:0.0 ref:0.0 spec:0.0 shadles: enabled

I’ve never seen a more appropriate typo :stuck_out_tongue:

You can also achieve a fish-eye effect by playing with the lens settings of the camera in Edit Buttons and using Panoramic view in the renderbuttons.

Hi @ner,

the shader settings you suggested do not change the situation. :frowning:
Especially the shadeless option is not working since the glass
material of the lens turns out to be completely white. But thanks
for your ideas anyway :slight_smile:

Hi 4Daniel,

The camera settings do not provide the desired effect because
the Pano option does not work for yafray raytracer :frowning:

As far as I can see I’m busted :-/
I can’t see why they didn’t come up with an “exclude objects”
button for the shaders like 3ds max had it about 10 years ago.

Well, I’ll try some other things. Maybe I can handle it with a
matte material or single sided plane between the lens and the
scene… Otherwise I have to fake it and render the central part
of the image where the lens shows up seperately without the
lens and combine the two images…

I’ll keep you informed.

Beste regards, serum…

all white? can you upload a .blend?

all white? can you upload a .blend?

It’d be all white because he turned shadeless on methinks:

Especially the shadeless option is not working since the glass
material of the lens turns out to be completely white

yes, but when alpha is set to 0.0 it doesn’t really matters

Here we go for the .blend file:


This is with the shadeless option switched on.
Switching it off leads to the rflected lense on the cubes,

Best regards, serum…