Exclude Object From Shadow Casting

Hi All,

Is this a texture and lighting post or rendering…?

I have a plane, a sphere and a cube.

The light casts a shadow from the plane and sphere onto the cube.

Is there a way to make the plane not cast shadow, and still have the sphere cast shadow? In 3DSMax it is simply a property of an object itself. A flag called “cast shadow”. Does blender support a per object exclusion on shadow casting?

Fallout Boy tagline? [[groans]]

annnnyway…

Well, not so much. There are ways, but being Blender it’s not that straight-forward.

For shadow buffer shadowing, yes, there’s a button on the render pipeline called Shadbuf… turn it off, no buffershadows. The button to it’s left, Traceable, will in fact turn off ray tracing lights shadows, but that’s not all… it’s truly not detected. An object that was behind it and obscured will now be visible as though the object wasn’t even there. (cause, well, it’s untraceable.)

You can have lamps only illuminate things on their own layer, and this is a good way to have raytraced shadows on some things but not others… put them on the same layer, set the lamp to no shadowing and layer only.

Or, you can do it in reverse, put everything where you want it and light it like you want, then move the things you do want to have shadows to a different layer, duplicate your non-shadowing lamp and put it on that layer, setting the Layer and OnlyShadow flags… much easier to balance the light levels this way.

Welcome to Blender. It ain’t 3DSMax. :smiley:

Thanks,

The lamp affects layer technique might just work…