Exclusive light not work with shadows?

I try this features and seems not work, maybe this is a bug?

here is the example.

did you turn off ‘ray shadow’ for your lamp in the lighting buttons?

yes, because i use buf.shadow, please check my exmaple