Exit code 3 (file not found) when I use "start new game" actuator

Hey guys,
Suddenly I start to receive “Exit code 3” (error) in the console, when I use “start new game” actuator. Only when I work and save the file on my main PC, when I work on the other PC and save everything is fine, but if I open it on may main PC and save it, I start to receive Exit code 3 (error) again.
So I can not change blend files in-game anymore(go to world map, start next level…etc)

P.S. I think this happened after some major windows update…any thoughts?
I already tried reinstalling about 1234563 other versions of blender…same happens on the main PC, everything is OK on the other 2 PCs.

It’s just the logic brick, not a script right? So the directory should be the same as where the blend file is? Hmm. Have you tried checking the current working directory? I would run that in a script and make sure it’s the same as what I would expect.

I have 23 levels that works and the 24th doesn’t. I’m building the levels from the same blend file(base_level.blend) 24th works, when I save it on my other 2 PC(with exactly the same game folders structure, actually I use dropbox and it automatically update each file everywhere)
But it doesn’t work when I save on my main PC. I made 23th level yesterday, today I made 24th and it just does not work. When I open lower levels like 23th or 22th and re-save them…they also “breaks”…just from today everything is fu*ked. :slight_smile:

Woah… weird. So the other levels work on your main pm too, until you save them, right?

Yes, that’s right! Weird indeed.

did you open anything with 2.79?

it does weird shit to the pointers etc and they don’t recommend mixing it into workflows using older files


  • When using add-ons in Blender 2.79 that take advantage of the new data-block pointer properties, the resulting .blend files can’t be opened in earlier versions of Blender. Attempting to open such .blend files in Blender 2.78c and earlier may crash. "

Yes, I noticed that. However, it is not connected with 2.79. I’m not using it since before I started TJ3 development.

Relative vs absolute path? Either in the actuator or in a library linked into the final blend file.
What happens if you use bge.logic.startGame(path) instead?
Check the outliner for external files that could be missing.

Search through blenders source to see what generates that message, and figure out what condition is causing it to be thrown.
Check permissions/ownership of the files? What if you start blender as administrator?

Also, I’d suggest using git or svn instead of dropbox…

I’ve checked everything. All linked files are relative. bge.logic.StartGame(path) do the same thing.
However with 2.77 it works. Strange, it doesn’t work with 2.78a,b,c/2.79/2.76/2.75/…etc. It works only with 2.77
And it worked with 2.78 till today with 23 levels for 3 months…obviously, it is not a problem with the blend files or scripts It seems a recent win update or drivers I’ve installed are messing up with blender 2.78. Maybe reinstalling windows will fix it. :slight_smile: (last install was 2010 and updated with win 10 in 2016)

  • this mystery is covered with darkness, my friend, I feel a dark force here.

lets not rule out hardware failure.

Ok, you try and tell me what happens on your PCs.
Here arethree files “1.blend” and “2.blend” and “launcher.bat”.
Launcher.bat opens “1.blend”, then press “space” to load 2.blend. Check console.
You can also open “1.blend” in blender and try , I receive another error - “mainloop.py…something”

Put the files in the main Blender directory.

Again…those files are created and saved with my Blender 2.78c and they don’t work. If I create and save them with 2.77 they work.

Hi, I opened the 1.blend in blender 2.78c, started the GE and nothing happens when I press spacebar.
I got following message in the console:
Yielding control to Python script ‘mainloop.py’…

Yep, and if you open it with launcher.bat you will get Exit code 3 error.

I’m skeptical of the path “//1.blend” The // is unique to blender to represent relative the currently open blend path, and it may be messing up where blender thinks its running from. Try using:

Ball.exe -w 800 600 32 60 -c ./1.blend


Disclaimer: Ball.exe does not exist, and I don’t run windwos anyway. But ./ should work (I think)

Ball.exe is just renamed blenderplayer.exe :slight_smile: I use “expandPath()” in the game…same happens.