Expert problems


(Hirpo) #1

:-? I hope someone can answer these questions:

           -Why mp3-files don´t work in exe-games?
           
           -My textures wont draw correctly. they´re too messy.        They don´t  slide smoothly from color to color, they are too sloppy.

It´s driving me NUTS!!! Help!!!


(Riskbreaker) #2

Now Im no expert, but i think i know something here:

-mp3s wont work unless you save the output as a dynamic runtime

-Texture’s ‘slopiness’ may be due to jpeg compressions…maybe…:slight_smile:


(wiseman303) #3
  1. What RISKBREAKER said.

  2. The game engine seems to run in 256 colour mode. If you have an image that has a gradient in it, like a sky picture, it will have obvious bands of colour in it. This is because the image is being converted into 256 colours by the game engine, and all those in between colours are being lost. Try not to have too many gradients in your textures, or use lots of noise to cover up the transitions.


(Pooba) #4

No, the game engine can’t run in only 256 colors, there has to be at least 8 bit color in there. That’s why all of the vertex colors can be assigned, and there’s a bunch of those colors.

About the mp3 thing, i’m having some trouble, i try to import an mp3, but it says not a valid file. All of the files i’ve tried say that. What’s up with it?

Pooba


(Pooba) #5

I discovered something! You have to have the key file installed before you can add mp3’s into the game.

Pooba


(saluk) #6

Pooba, 256 colors IS 8 bits. Blender runs in more than 8 bits, (16 or 32, I think it is based on what depth your os is at). But it converts each TEXTURE to only 8 bits. So if you make your texture with more than 8 bits, use your paint program to convert it to 8 bits before you put it in blender. Your paint program can probably do a a better job at limiting the colors than blender car, and make your texture not look so shabby. Most of the time, your texture might be using only 120 different colors even though it’s saved at 16 bits, meaning that you can convert it to 256 bits without losing any information whatsoever. But if you leave it up to blender, it won’t do such a good job.


(rav_bhara) #7

I remeber posting a topic about blenders graphics. Some of the colours of the textures do look a bit simplified. Graphics does have a lot to do with the graphics card but the program has something to do with it as well. Ive seen programs which pump out a lot more graphics and ploygons, but if blender were to be changed it would probably lose portability


(saluk) #8

Actually, the reason textures look bad in blender is due to mip mapping. Either my graphics card has bad mip-mapping, or blender does, but if you turn mip-mapping off it looks soooo much better. Sharp lines that are far away look worse though.


(jeotero) #9

for the mp3 part

  1. export as dynamic runtime, dont forget to copy the python.dll and fmod.dll

  2. the mp3 must be plain vanilla, that means NO VBR, etc. that works for me in must of the cases, there also another post about that subject.


(doogs) #10

Mip Mapping,

My card look good. you have bad card salookz0r

doogs


(Hirpo) #11

The subject name says it all… 8)


(OTO) #12

Hello
imho (i’m far from an expert) Game Blender is a full 32 bit game engine.
And i don’t see any texture loss in “game mode”

Bye
António


(jeotero) #13

maybe check the runtime settings maybe you forgot to select the bit depth from there


(saluk) #14

I think it depends a lot on graphics card, but even on my good graphics card textures come out looking a lot worse than when I made them. Mip-mapping blends textures together so they don’t appear pixelly, and it does it more for objects that are far away than those that are close. You can even see lines where it switches from small mipmapping to medium mipmapping. Mipmapping is good though, because it makes things not look so bad when you’re really close to them.

And I don’t experience this with other game engines, so it has to be blender’s fault:)