EXPLODE4.py, original shattered mesh (update:31/08)

The locating the ground part of the script created a new Empty at each frame . Corrected now .

management of texture and material .

updated v0.3 . Same address .

updated v0.4 . Same address .

Does it require a full Python installation? I’m getting a

Traceback (most recent call last):
  File "explode4.py", line 186, in ?
TypeError: iterable argument required


No need of a complete python .
Try the file :

if you want to make a test by yourself, do not forget to link the scrpt to the explodes object. There is a little tut’ on the same page :

I get this error:

Traceback (most recent call last):
  File "explode4.py", line 379, in ?
AttributeError: sel

several times, presumably one for each frame. The mesh fails to explode.

The face’s sel is a new property of the python API . It was added a few weeks ago so the script works but only with a very recent blender compilation .
You can find these files at this address :
or directly at the gabio’ download page .

ah, that makes sense. I’ve got a recent CVS build laying around here somewhere, but I like to stick to the release for everyday use.

I’m trying to use this too, but as a complete n00b I’m a bit confused. I get an error message that says:

traceback (most recent call last):
File “explode4.py”, line 267, in ?
Attribute error: unknown object specified

Can anyone shed any light on the situation? Thanks!

as said in the other page
could an empty postion the shatters force. this way it could act like a soda can or something…

Example, move the empty around and the shooting axis will change by the emptys location

Can someone explain the empty thing please - I don’t understand the concept or how to do it?

Thanks in advance

There is yet a mesh named FORCE to change the shooting axis, and the power too . I will make some screenshoots to show how you can use it .

At this line, there is a call to a mesh named MESHT to draw
the trajectory of the exploded mesh’s different pieces .
But to activate this tool, you have to set the variable TRAJECTORY to 1 :
It seems to work correctly in the file :

I don’t know if I’m being really stupid here, but it is still not working.
All that happens when I get to the desired frame for the shatter is that the object loses subsurf. So presumably this is the point where it is running the explode4.py script.

I haven’t set an empty as I don’t understand this, can someone please explain or suggest other things.


Sorry, but :
you can’t use subsurfed mesh with this script .
you can’t preserve normal smooth effect neither.

… for the moment .

Now, we can but the script will be updated only in a few hours .

in fact, the new script can’t yet work with a subsurfed mesh but can prepare one with a subsurfed division (i hope i’m clear) .


First off, let me say thank you for creating such an intense explosion script. It looks very exciting and I am really hoping to make some great use of this script! Great work and very nice of you to share with the community.

Unfortunately, I am encountering some issues getting it to work. I started trying it with the latest official blender release and had some error messages. I noticed your comments here about using the CVS release and grabbed the release shown here:


It is labeled as a CVS release. Is this the correct one?

Now, when I open your file and provided on your website and closely follow the instructions, I no longer see errors. However, I see no explosions either. The only animation I see is the animation of the projectile.

I am following these instructions:


But nothing seems to happen at all when I hit alt-p on the scriptlink script. No meshes are renamed, no meshes are created… nothing. I felt like I had something to work with when I had error messages. Now I have no idea what it is doing.

Any help you could provide would be very appreciated.


Bad joke ! :frowning:

It seems harder to play with automatic script links now (tested on 2005/05/23 RC blender 2.37) . There is a new button in the script link window : Enable Script Links .

The animation playback works correctly if you push this button .

Allright! Progress!

I clicked the button as you suggested and sure enough, suzanne bit the dust! Very cool! I played around with it a bit by selecting different parts of suzanne… even the entire suzanne… and getting it to explode.

Then I tossed in my own mesh and tried it and had some success on the first try. Unfortunately, I had problems getting anything to work after that. I finally realized some quirkiness that made it work or not work for me. If I have the mesh selected that is going to explode, it works. If I have anything else in the scene selected (when I animate) it does not work. Is this expected? What if I wanted to explode 3 things in a scene at different times? Is this even possible?

Gravity doesn’t seem to be working for me right now either… back to the experimentation board. Just wanted to give you some thanks and the update.