Explosion has gray area in compositing


(AerialBot) #1

Hi

I’m creating a scene that involves a Blender explosion over an image background. I’ve a few other digital objects also in the compositor, but the explosion is the only thing not rendering onto the image background correctly; there is the gray ‘default’ background where the smoke domain box is located. How do I get rid of the gray and leave only the explosion?

If it helps, I have two render layers and two view layers. The explosion is located on both views but only on the second render layer. Both the domain and the object exploding have a pass index of 2.

Help would be greatly appreciated.

Thanks,
AerialBot


(AerialBot) #2

So…

No one?


(El Director) #3

sample image or blend file???


(AerialBot) #4

Hi Director

Here are two images. One is the explosion itself rendered on the image, and the second is the node tree.



Thanks for your help.

AerialBot


(El Director) #5

Did you check the “Transparent” box under “Film” in the Render Settings tab?


(Mandalorian) #6

As El Director said, checking “Transparent” would help eliminate the grey background. However, there will still be a problem, as the id mask for the box domain is still a box and not limited to the explosion volume itself. Since your explosion render layer includes other objects, this id mask will keep parts of those other objects as well, as you can see in your examples where the gray box includes a small amount of the brown ground in the bottom left.

Having a separate render layer with only the explosion would likely help solve that problem, and eliminate the need for the id mask in this instance.


(AerialBot) #7

Hi Director. Hi Mandalorian.

I’ll try that.

Thanks,
AerialBot


(AerialBot) #8

Hi Director. Hi Mandalorian.

Apparently, ‘Transparent’ only made the domain completely black. Then, I moved the explosion entirely to a third layer, created a third render layer, and rendered again (‘transparent’ still enabled). It works!

. . . Now my node tree is all wonky and I have to fix it somehow.
But! The domain problem is gone.

Thanks!
AerialBot


(sundialsvc4) #9

Oh, node-trees get pretty “wonky” pretty quick. :yes: But, if it works . . .