Export 3ds? Import Doom 3 md5 ?

blender is supposed to be able to export 3ds files… but I only see 4 options under File -> Export and see no 3ds option…


I’d also like to import a MD5 from Doom 3 — none of the aformentioned import formats work.

Oh come on. Nobody even has a clue?

please? …

3ds export works fine for me

Are you using a different version of Blender? Mine (2.42a) seems to have about 20 export options

yeah i have a ton of export and import too. make sure you have 2.42a

I do have 2.42a.

I have installed Blender 2.42a from portage (Gentoo’s package repository)
, so maybe it lacks some of these things…

Anyone here use Gentoo?

When in “User Preferences” mod thingy, is it under File -> Export ??? (only 4 things there!)

Someone with the same problem with Blender and Gentoo discussed it on a bleder IRC channel, and apparantly resolved it. I have yet to try this mysef, but here’s the chat:

<Zeroth404> could someone tell me where the "export to 3ds" option is located?
<person1> file>export>
<Zeroth404> person1, I only have 4 options there
<person1> check your scripts Zeroth404
<person1> the 3ds export solution it's based on python...
<Zeroth404> person1m, and everytime I click the button to the left of the file menu and select something other than "User Preferences" I lose my file menu
<person1> that's weird..man..
<Zeroth404> person1, what about scripts?
<person1> check your path where your scripts should be..
<person1> and check that you have the 3ds exporter script there
<Zeroth404> how do I do that?
<Zeroth404> where should it be located?
<person1> check .blender/scripts/ at your home
<person1> or your python path in preferences
<Zeroth404> ever use gentoo?
<person2> I use Gentoo
<Zeroth404> kay
<Zeroth404> I'm on gentoo
<Zeroth404> I figured there might be a USE flag for the options or something
<Zeroth404> but there isnt
<Zeroth404> person2, have you had to do anything special with gentoo to get certain features like that working?
<Zeroth404> if the scripts don't exist in my home directory, I dont know where else they'd be
<person2> hmm
<Zeroth404> hmm indeed
<person2> I only have the NLS use flag option.
<person2> I suppose re-compiling might be in order... then watch the compile configure steps and see if the ebuild omits some of the good stuff.
<Zeroth404> same
<Zeroth404> Ive already tried
<Zeroth404> I had an old version, then I moved to 2.42a
<Zeroth404> same probs with both
<Zeroth404> I might be forced to just disregard portage and get it from the net
<person2> I'm guessing to hit the mailing list and email the gentoo ebuild maintainer.
<person2> Also...
<person2> The ebuild maintainer might have an ebuild you can put in your PORTAGE_OVERLAY directory
<Zeroth404> bah
<Zeroth404> if it were known, it'd be fixed
<person2> Zeroth404: You could recompile and save the entire console output as text... then submit a bug report that the export option is missing.
<Zeroth404> person2, whos to say its a bug?
<Zeroth404> maybe there is some obscure use flag that isn't mentioned
<person2> Zeroth404: Well... if it's not working as it should and you can reproduce the condition... and I have the same condition... it's likely a bug.
<Zeroth404> I don't have access to my coputer at the moment, if you'd like to file a bug please do.
<person2> Zeroth404: As soon as I finish the morning updates I'll do the bugreport
<person3> Zeroth404, works here on gentoo
<person2> person3: Click File... goto export... how many items do you have?
<person3> all there + the ones I added myself
<person2> Zeroth404 and I only have 4 by default.
<person3> ahh btw, I've already had this bug before but I'm using unmasked version
<person3> drag down top bar.
<person3> paths -> scripts <click update> button after setting it to blender scripts path
<person3> put bar back up.
<person3> CTRL + U (save the scene)
<person2> What should the blender scripts path be?
<person3>  /usr/share/blender/scripts/
<UnNamed> save the user prefs (user config paths are not saved via normal saving)
<person2> Which one is scripts?  I have YFexport Fonts Render Textures Python Tex Plugins Sounds Seq Plugins and Temp
<Zeroth404> interesting
<Zeroth404> person3, the masked version fixes the proble, or you need to update the scripts?
<person3> no masked version is ok.
<Zeroth404> I've already unmasked 2.42a
<Zeroth404> keyword unmasked
<Zeroth404> not hard unmask
<Zeroth404> yeah, I'm using the latest version
<person2> Once I drop the toolbar and click paths... which one of those do I put the scripts path in?
<Zeroth404> person3, what do you mean by "drag down top bar" ?
<person3> person2, Python under file paths
<person2> Zeroth404: move your mouse to bottom of the menubar so that the cursor is an upward/download pointing arrow... then click and drag the toolbar down.
<person3> Zeroth404, click and drag down on the line between top part and 3d window.
<Zeroth404> does that expose more buttons?
<Zeroth404> like my *missing* file menu?
<person2> I don't have a /usr/share/blender directory... wtf
<Zeroth404> person2, try /usr/local/share/blender then
<Zeroth404> person2, or maybe /opt/blender
<person2> hmm...
<person2> nope
<person2> Where did you find it?
<Zeroth404> maybe /opt/share/blender?
<Zeroth404> I haven't, I've no access to the machine atm
<person2> doh
<person2> i'll try locate
<person2> /usr/lib/blender/scripts
<Zeroth404> hah
<Zeroth404> whodda thought
<person2> nice
<person2> now there are more than 20 of them.
<person2> person3: Thanks
<Zeroth404> person2, file a bug report will ya?

My directory was in /usr/share/blender/scripts instead of the other guy who’s path was /usr/lib/blender/scripts.

drag the top menu bar down, click File Paths, click the folder button for Python, and type in that dir.

and thats that folks. Solved.

though it doesn’t save this, I have to do it every time I start blender.

edit: it still doesnt save, but if I make a symlink /home/user/.blender/scripts pointing to /usr/share/blender/scripts, it works on load.