Export as game engine runtime addon NOT working in UPBGE 2.5

GUYS I NEED A SOLUTION EXTREMELY QUICKLY!!

Guys, I need the soulution to my question IMMEDIATELY! ! When I use the addon “Export as game engine runtime” in Upbge 2.5 modified Rev 5 ( i use this version because this version has fixed some mouse sensor issues), and when i export a game using this addon, it shows this error:

And when I ignore this message and go the file where i exported my game, there shows only 2 files, one is the .exe one and the other is 2.79, but this whole game folder does not consist and dll files like the older versions exporter used to make after exporting a game, and when I run the exe file, it shows some dll errors, I need the solution for my question immediately, please guys help me out, thanks

It is not a problem from addon, it is a problem with your folder permissions (i tested the addons and it works well).

P.S. Please mate, relax when posting. It seems that all your questions need to be solved inmediately.

1 Like

Bro, can you tell me how to fix this issue? And yes, I think you know that brackeys organised a gam jam which will start tomorrow, hence I am in a hurry, please tell me what to do to fix this issue?

Hey dude, please answer me​:sob::sob:

r click upbge shortcut -> execute as admin. Now try to build a .exe again.

Oh ok, will try

No bro, it doesnt work, it gives ne the same error, please someone help me… i have only 5 hrs😭

Please lordloki, u are my only hope…please help me😭

Please…help
.
.

put this line in a text file and save it as “Game.cmd” (or similar). this runs the blenderplayer.exe without having to export any blend. after that you can double click on the cmd file like an exe and itll run your game.

cmd /K "blender\blenderplayer.exe game.blend"

simply have a “blender” folder with a copy of blender in the same place as your launcher/game blend.

mygame(folder)
----game.blend
----game.cmd
--------blender (folder)
------------dlls/exe/2.79 folder/etc

this only works for windows, i dont know how to do similar with linux, although i imagine its a bit like this.

1 Like

Thanka dude for this idea, but I am extremely sorry because I forgot to tell in this thread that my issue haa been already solved! It was my anti virus software which was causing this, but that thanks for this idea, it will be helpfull for the person who is stuck in the same situation as mine, thanks.

Yeah it has to do with the path of where your game is going to be saved have you perhaps tried creating a folder where you can put your game in but on desktop?

Ive had issues like this in the past back when i used to use BGE Blender 2.60+ versions sometimes i would get the traceback error calls

But it seems like you got your aid judging from the replies you got above here …

All the best buddy!

Fred/K.S

1 Like