Export to Cal3D

I’m running on Blender 2.5. and have Python 2.5.1 installed. I’m running into a problem while trying to export with Cal3D. After I click on export, I get an error message which says, “python script error: check console.” I checked the console and the message on the console reads:

Traceback (most recent call last):
File “<string>”, line 1101, in export_cal3d_ui
File “<string>”, line 887, in export_cal3d
File “<string>”, line 121, in best_armature_root
IndexError: list index out of range
I have already made sure that my pythonpath is right and checked in Blender to make sure that the Python is set on the right path right inside Blender. Anybody have any ideas on how I can fix this problem? Any help would be greatly appreciated.

I’m having exactly the same problem. It would be great if anyone can help us.

A bit in reply (having other CAL3D issues but this came up in a search. Don’t know if you fixed the problem but that usually happens when you try to export and armature with only one bone, trying to export something with more than one ‘master/root’ bone (accidentally trying to export two armatures?) or you’ve not assigned an action to the rig yet - even a basic one is enough to export.

Well that what happened to me… I used only 1 bone, I’ll try with multiple bones next time.
Thank you kindly! :smiley:

You can try the version I’ve worked on, I think it supports some things that others don’t


I love your script. I have been using it for quite sometime. Thanks for maintaining it~! :smiley:

cool, no way, I never thought I would get any positive responses for that

This script is basically customized for me (and my modified version of
sprcal3d which has LOD and so on ).

If you have a version of sprcal3d that supports cal3d model LOD … well
… we surely wouldn’t mind to have it as well :wink:

I do have a version of the crystal space sprcal3d plugin that does, but there are some bugs I recently noticed, that didn’t show up before. Also I don’t get a lot more frames per second even with a high lod level, possibly that’s just the way modern hardware behaves, it cares less about small differences in triangle count.

If you think you can work with it I will upload it for you, but I don’t think it will just plug into whatever version of CS you are using, partly because it won’t be the exact same build I started with.

I’ve tried your script too, bookeater, it works better than the bundled one for me… but I get an error in the console after telling me that my bone influence is less than 1, though I weighted it all to 1 (if i did that properly, maybe not) Also, I don’t get the materials file. Anyone have any suggestions for finding / making the mat file?