Exported FBX won't write most textures

Hello,
I am exporting a model to FBX. There are a few objects and a few materials in it. All data is packed into the model, including textures.
When exporting, I choose Path Mode > Copy, because I want to write all textures into image files, but only one of them is written.
What am I doing wrong?
Shaders are as simple as possible - only principled BSDF with image textures or base colors.
Maybe this is related to the fact that I’m using alpha version of Blender 3.0, but I also tried copying the objects into a new scene in Blender 2.92 stable version, and the issue persists.
I attach the model saved in v2.92.
Don’t mind weird looking meshes. I deleted most of them to make the file smaller.

These are my export settings:

Here you’ll find the Blend:

https://drive.google.com/file/d/148qUt6AkQPAhDYPwsh4KrGXvPbuaPg17/view?usp=sharing

Okay, I half-solved it.
I ticked “Embed Textures” next to Path Mode setting, and all textures got written into FBX file.
Though, this is not an ideal solution, because not all software supports textures embedded into files, e.g. SketchUp won’t import them without a paid plugin.