Exported OBJ from Blender messed up in 3d viewer?

I’ve been getting used to the 2.8 interface, so that means taking my amateur modeling skills and making lots and lots of LEGOs. :stuck_out_tongue_winking_eye:

I exported this one with no duplicated vertices and no unapplied modifiers, yes it goes from this:

to this:

Is this a problem with the standard windows viewer, or with blender? All the other models have exported fine, i.e:

1 Like

Try to import it back to see where the issue is. Or open it with MeshLab.

This looks like it is because the mesh in blender has Ngons. When you export it to obj it’s converting those into triangles.

when you export the obj go to the settings and uncheck triangulate faces.

If that doesn’t work you can post the blend file so that I can check it out and see if I can source the trouble. :wink:

I also always select Objects as Object Groups and uncheck the Obj Objects…It makes a big difference in other software I use… same as exporting from other software…as if not checked in this way, can cause the blender import to fail.

1 Like

Make sure to convert all meshes to triangles before export, use Ctrl+T in edit mode.

1 Like

Thank you all a bunch! @Josip_Kladaric’s method was the only one to work (thanks!). Problem is solved, and this doesn’t matter in the long term but it’s piqued my curiosity: since triangulation led to an uptick in the number of faces (naturally,) does that decrease performance as opposed to switching to a file type that supports n-gons?

I’ll likely open a different thread with that question, since it doesn’t look like a quick-answer one, but I’m testing my luck :wink:

1 Like

Almost all viewers or render engines must convert to triangles in order to render the surface, they just don’t always require you to do so. So if there is any change in performance it will be a positive one.