Exporting movie codecs on Linux

I’ve got an “industry / graduation night” in a couple of weeks and I’m wanting to fix up my student reel.

We did the work (at the school) in Maya, though I was at the time using Blender to make my characters etc. At the time, I mixed my reel with AfterEffects / Premiere. Unfortunately, the day after handing my reel in, my external drive fell over losing all my files right before I was going to back them up. It was one of those freak timing things and I have only slightly outdated Maya files plus the RAW (taga) avi file of my submitted reel, which I want to update.

I found I could import the reel into Blender as one long strip - straight into the compositor. Neat!

However, when I go to export the thing, all I get are conflicts and crashes. I can’t seem to get a working output codec. The school will be showing the things in Quicktime mov or AVI, and I want to make sure my reel is going to be compatable (screwups are unforgivable - I want a job out of this night)

I am on Ubuntu Linux here.

Can anyone help?

what settings are conflicting and crashing?
Are you using ffmpeg to output?

I think it’s stopped failing now hat I changed the “save animations” location from my external hard drive back to /tmp/
…seems Blender doesn’t like saving the files elsewhere.

…so now, at least I am getting an ffmpeg video. Still, with “Multiplex Audio” selected in FFMPEG options, codec MP2 at bitrate 128, I’m still not getting sound with the video. I’m assuming the compositor still doesn’t make sound?

Not that it matters, they are saying the format needs to be AVI-raw and the compositor definately doesn’t have sound with that format… anyone know of a good mixer and rendered RAW videos with Linux?

You can render somewhere other than /tmp. I do it all the time. Rendering to and external drive might not be a good idea, however.
You can get audio out of the compositor, you just have to have audio in the VSE and chose “multiplex audio” in the ffmpeg settings.
Strange that they are saying that they want raw AVI, as the files will be considerably larger than any other type of AVI.

Not that strange. I think it’s because they will use AfterEffects etc etc at their end to merge everyone’s videos into one long playblast, so for quality they don’t want to compress over compression.
The reason I wasn’t getting any sound was that the RAW avi import was resulting in a silent audio layer. Looks like I’ll have to extract the sound maually and import separately as a WAV.

… or, since they’re using AE, provide the soundtrack with it…

That would be a good idea except they are getting someone in more of a secretarial role to just bung everyone’s demo clips together into one long demo reel. Separate sound would be one more thing which would be bound to go awry.